Suzuki GSX-R Motorcycle Forums banner
1 - 5 of 5 Posts

· Registered
12 Posts
Discussion Starter · #1 · (Edited)
Just thought I'd share some potentially useful information for other users as I've gained so much knowledge from these forums

I've got an L2 GSX-R600 Em Pro ECU and race loom.
I don't have any documentation or the data cable, however Yoshimura kindly sent me a copy of the software - refer below

The battle I've been having is communicating with the ECU at all, not getting any response whatsoever using the EMPro software
as so far I have finally received a response from the ECU

Using the schematic here:
I have an FT232RL. - this one to be precise

OS is Win XP SP2 - it's actually running via Virtualbox [which was a yet another variable that I thought was causing me problems - it wasn't an issue as it turns out], VirtualBox also makes it much simpler to just load up XP or another OS without the hassle of dual booting or having an old dedicated machine to be able to do this.

I was trying various port settings - it's working with all settings at default with one exception - the Yoshimura software sets the data rate at 4800 - see screenshots
Blue Rectangle Font Screenshot Computer

Port settings - NOTE, looking into the possible advanced settings for some things which would prevent communication - see screenshot - these are default settings for this chip/driver
Rectangle Font Screenshot Parallel Software

One important point to make is the COM port should be set between COM 1 - COM 4, as I had tried various USB to serial devices, there were other unused [disconnected devices on the system] ALSO some drivers automatically loaded the COM ports into the higher range, COM 13 was common among the other adapters I tried and COM ports 1 - 4 were unavailable in the drop down list as a consequence of the previous device driver installations.

Higher numbered COM ports won't work - I cannot find the link right now, but tip was COM 1 - COM 4
This is confirmed by reading the ini files in the Yoshimura\EMPro\Conf directory for the various bikes/ECUs - most have port 1 set in those files.

If those COM ports 1-4 are unavailable for selection, close the above dialog window and go to Device manager main screen -> menu -> show hidden devices - see screenshot

I removed all of the various drivers for COM ports and related USB devices and started from scratch, installing just the driver for the FT232RL

Azure Rectangle Blue Font Screenshot

This setting for the USB serial converter is also default for the driver with load VCP ticked as set by the driver installation - see screenshot
Rectangle Azure Font Software Screenshot

In summation - the only setting which MAY need to be changed is the COM port number - noting that I haven't read anything from the ECU as yet, just established communications.

Onto the actual cabling - I was trying the schematic linked above in the K7/K8 GSXR1000 ECU flashing thread for the connections at the USB -> serial connector
FT232RL - CTS -> ECU pin 17
FT232RL - RXD -> ECU pin 15
FT232RL - TDX -> ECU pin 16
FT232RL - RTS -> ECU pin 29 + 5 volts

I read about similar issues here regarding EM Pro -> ECU communications

Now almost accidentally [damned happy accident if you ask me] I removed the 5 volts from pin 29 and didn't reconnect the wire properly, so there was no connection between FT232RL RTS and ECU pin 29 - I actually received a response from the ECU!

So I had the following connections
FT232RL - CTS via 1K resistor -> ECU pin 17
FT232RL - RXD -> ECU pin 15
FT232RL - TXD -> ECU pin 16

I can see the USB -> serial adapter communicating with the ECU [LED's flashing] - something that it wasn't doing at all previously
I get this response - See screenshot

Rectangle Azure Computer Font Screenshot

I have downloaded the correct GSD files for the ECU from the Yoshimura website and placed it into a folder 11GSX-R600 folder within the \Data directory.
That isn't the issue.

However, the issue I have is the version of the EM Pro software is 1.0.30 and it doesn't have the correct files in the \Conf directory for my ECU - they would likely be 11GSXR600.ini and 11GSXR600.GSZ, which is a binary file.

If anyone has a working version of the EM Pro software with those files in the Yoshimura\EMPro\Conf directory that they can share I can confirm correct communication as far as reading the ECU MAPs and other settings.

I hope the above helps someone, if it wasn't raining cats and dogs here all weekend I would have given up on this two days ago.


· Registered
12 Posts
Discussion Starter · #3 ·
No unfortunately, Yoshimura in the USA were very helpful getting the older copy to me, but as they no longer run a race team they didn't have the later version available

I went round the internet and back again trying to find the later version without success - I did have some leads, people on facebook etc, but that didn't come to fruition unfortunately

· Registered
2 Posts
I contacted Yoshi about software for the EMpro on my outfit, I told them which engine was in it etc and they replied with a link to download the software (expiring link). They seem to have only sent me a link to software new enough to include my engine and nothing newer. I have version now but I've checked the dir's and it only contains config files up to '09 engines. They even sent me a serial number to unlock it.

If it helps, and i hope this is ok, the Yoshi staff member I dealt with can be contacted on [email protected]

Good luck. (y)
1 - 5 of 5 Posts