Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 20 of 25 Posts

·
Registered
Joined
·
84 Posts
Discussion Starter · #1 ·
HOW FAST HAVE YOU RODE YOUR BIKE (600s) and WHEN DOES YOUR REV LIMITER KICK IN AT. I CAN'T GET PASSED 10K ON MINE IN ANY GEAR, THE GUY AT THE SHOP SAYS ITS NORMAL, SO I BROUGHT MY BIKE BACK HOME.I'M GOING TO FIND ANOTHER SHOP 2 TAKE HER 2.
 

·
Registered
Joined
·
569 Posts
That's definitely not normal to not be able to hit redline.
 

·
Registered
Joined
·
1,910 Posts
that shop is not telling you the truth, The 600 starts making power at 10k and revs out just past the redline mark (I cannot remember what number is there-15.5??). there is definately something very wrong with your bike. You will probably not get to the limiter in 6th (mine would not on stock gearing, have not tried since gear down a bit) but it will in any other gear. I have seen my speedo read over 170 but I don't think it goes much faster than 155 or so.

edit: I just got home and looked at my tach, redline is 14.5, I am sure the tach is optimistic but you get the point.
 

·
Registered
Joined
·
250 Posts
I shift a lot of times around 13,000, ive hit rev limiter only twice in second and third gears and that was about 15k rpms..so u may have a problem with the tach..have someone put it on a dyno..
 

·
Banned
Joined
·
15,031 Posts
in 6th gear, depending on the head wind -


but before this discussion goes any further - KNOCK THAT CRAP OFF ON THE STREET
 

·
Registered
Joined
·
138 Posts
When I had my 02 600 dynod it went to 162.8 mph.. Cant remember what the redline was but I'll check the sheet when I get home..Def got a problem if you cant hit the redline though.
 

·
Registered
Joined
·
332 Posts
I have only had my K3 600 for a month or so but i have seen 161 MPH on the Digital speedo, for some reason i dont remember looking at the rev counter, but it felt as if it would go a bit more.

I know that digi clocks are about as reliable as a mini in the wet, so it was probably less!!!



Power Commander III, Yoshy end can and a clear track ahead of me!
 

·
Engine Tuning God
Joined
·
1,773 Posts
rev counter read 1000rpm high on gsxr's anyway
 

·
Registered
Joined
·
59 Posts
i have a 01 600 pipe,rk chain with vortec spocket -1 in front +2 out back and i saw 178 on my speedo but i know it is not right .i raced a friend of mine with a yosh piped honda 600rr i was right next to him and his bike clocked 172.as far as your redline issue there is def something wrong with your ride. i would take it to reputable suzuki dealer. it seems the aftermarket shop dont know anybetter. hope to here youy got your bike running better.
 

·
Bearded Viking Admin...
Joined
·
131,133 Posts
I know what the problem is... Your Caps Lock button is broken... :lol
 

·
Registered
Joined
·
5 Posts
check to see if your secondary throttle valves are opening and closing properly . when you turn the key on without starting it , the bike will perform a "self-check" . you will have to lift your tank , remove your air cleaner , look down your throttle bodies while you turn the key on . what you should see is the butterflies go from half open to fully closed to fully open then back to half open all on it's own . if they don't work like I described you'll need a multi-meter and start checking your signals to and from your ECM . let me know if they work or not . i'm not sure what your mechanical skill level is but it's not too hard to diagnose . if you need i can try to walk you through it . :)
 

·
Registered
Joined
·
3 Posts
When I had my 03 600, I was only able to get 157 out of it. It felt like it was pulling hard the whole time, but couldn't get past 157. There might have been a little head wind, but it seemed like the aerodynamics came into affect at that speed and it didn't have the power to continue to redline. No problem now with the K5 1000.
 

·
Banned
Joined
·
29 Posts
I have a question without starting a new thread. What gear are u all in when hitting this 160ish? and what gears? Mine seems to top out in 5th redline 15k or so @ 163 spedo. When I shift it into 6th its like I dont have enough power to push it anymore and she slows down???

5th gear at red line is 163 if I shift into 6th it drops to 158 159ish and stays so I drop her back down to 5th so my boys dont run away from me. Bike is an 03 600 with slip on and power command stock gears.



-oh ps this test was done on a closed corse with professional riders-
 

·
Registered
Joined
·
377 Posts
i got mine 160 with room to go but i backed off (highway+wind= slow down) its an 06 w/ no performance mods but a slip on
 
1 - 20 of 25 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.
Top