Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 11 of 11 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Bike idles poorly, and runs poorly at low rpms. surges and takes a very long time to get rpms up when dumping the throttle while moving, while in neutral this is not an issue. I pulled the airbox off and inspected th air filter, clean. I gave it gas and watched the throttle plates, 1 2 and 4 appear to be moving in sync, number three has a noticeable lag in opening. what could be causing this? thanks in advance
 

·
Dreaming of buttsecks for years...
Joined
·
13,406 Posts
Considering that the 2001 600 should be fuel injected, the primary and secondary throttle plates are all fixed to a shaft and move in unison. The only way what you said could make sense is if it has a CV carb and the slide isn't moving in #3. At which point I'd question if you even know what you have.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #4
the bike is an 01, so yea its fuel injected. and its pretty obvious the throttle plates aren't opening in unison and when the plate finally does open it runs normally so I know what im seeing. like I said I don't know what could be causing this
 

·
Registered
Joined
·
6 Posts
Discussion Starter #7
code popped after I disconnected battery, c28. that would explain the hesitation at full throttle and inability to get to high rpms. so I geuss I need to change the whole throttle body? where do I find that part
 

·
Dreaming of buttsecks for years...
Joined
·
13,406 Posts
Yes, if the secondaries are stuck closed because of an STVA failure, it will limit power. I still want to see a video of them moving differently....
 

·
Registered
Joined
·
6 Posts
Discussion Starter #9
so I removed the secondary throttle plates and the code immediately went away and it runs a little better but I still cant floor it, or it will stumble heavily, maybe a fuel delivery issue? is the fuel filter in the tank? also I use 87 gas am I supposed to use a higher octane?
 

·
Hand-Eye Coordinator
Joined
·
6,529 Posts
Removing secondary plates is NOT a fix AT ALL. The secondary plates are ECU-controlled. If you smash the throttle, you open the top butterflies wide-open, and this causes a lean condition in low RPMs.

You need a manual and a multimeter. Go through the troubleshoot section.
 

·
Registered
Joined
·
6 Posts
Discussion Starter #11
thanks for the help,i removed the gas tank and fuel pump, there was metal shavings in the tank, not sure why. rinsed the shit out of it. turns out the fuel pump sump filter was clogged as hell, rust and debris were caught in the fuel pump housing and getting sucked into the filter every time I turned it on, the fuel line was also kinked. I cleaned the gas tank and pump and the filter, then fixed the kinked gas line and now it runs like a bat out of hell
 
1 - 11 of 11 Posts
Top