Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 6 of 6 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Changed the water pump yesterday flushed all the coolant and changed the oil. Today I noticed the bike would whine when I rev it in neutral. It’s pretty noticiable and I really think I would’ve noticed it before considering how thorough I check the bike. Any ideas what this could be? Also my regulator and or stator is shot at the moment, but I don’t think it could be that. https://youtu.be/85NWfB8KaJU
 

·
Dreaming of buttsecks for years...
Joined
·
13,416 Posts
Get a big flat screwdriver and press it hard against the waterpump. Put your ear against the handle and see if that sound is coming from the pump. The new pump might be bad, or just need time to break in.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #3
Get a big flat screwdriver and press it hard against the waterpump. Put your ear against the handle and see if that sound is coming from the pump. The new pump might be bad, or just need time to break in.
I’ll give that a look when the bike is charged up, but as far as I know it’s not coming from the pump. It sounds like it’s coming from the radiator or under the airbox. Might be the CCT? If so that would be a huge coincidence.
 

·
That’s Mister Chalet To You ....
Joined
·
7,744 Posts
Talking out my ass but: Is it possible you filled it up wrong and there's just air stuck where the pump is that it can't purge? If you're hearing a whine after changing the pump, it's just too easy to assume the problem is there.

Many out here know the procedure to properly flush cooling. I don't.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #5
Talking out my ass but: Is it possible you filled it up wrong and there's just air stuck where the pump is that it can't purge? If you're hearing a whine after changing the pump, it's just too easy to assume the problem is there.

Many out here know the procedure to properly flush cooling. I don't.
Yeah I listened to it and it sounds like it’s coming from the pump. Can’t be the CCT lol. I just hope it’s not actually damaged. I flushed and filled up the coolant as I would for a car. I’ll check out how to do it for the gsxr properly. Hopefully that fixes it, engine ice isn’t cheap 😟
 

·
Registered
Joined
·
8 Posts
Discussion Starter #6
Update for anybody out there or is having a similar problem. It’s the stator lol. Case closed 🤑
 
1 - 6 of 6 Posts
Top