Suzuki GSX-R Motorcycle Forums Gixxer.com banner

21 - 40 of 48 Posts

·
Registered
Joined
·
4 Posts
My orange wire was fried off the connection so i soldered it back down and light came on, but starter switch is still sticking making lights go off. gonna have to fix that too.
 

Attachments

·
Registered
Joined
·
2 Posts
Crush,
This is a great how-to, thank you! I was having exactly the problem described so I took apart the assembly. I am down to the copper piece. Although mine does not look melted, it does not move freely with the spring either.
There really isn't any melted areas to cut away, what do you think if I just sanded down the plastic a bit so the copper piece can move?
 

·
Registered
Joined
·
327 Posts
I tried this but couldn't get it to work so I soldered the two wires together for the headlight. The light stays on when starting the bike, but I haven't noticed any issues with that so far. Nice write up BTW.
 

·
Registered
Joined
·
15 Posts
Great write up, cheers!!

My lights wouldnt turn on after the switch decided to shit itself on a ride yesterday :hammer luckily i could start the bike by thumb pumping the switch for a while. Went to the bike shop and they wanted $140 for the right assembly, and couldnt sell me the switch itself, saved me some bucks!! :cheers
 

·
Registered
Joined
·
2 Posts
If this was causing the headlight not to come on, would there be power going to fuses? Because I'm not having any power going to the fuses, and my headlights just quit working.. everything else is fine.
 

·
Registered
Joined
·
1 Posts
Champion mate, i can't believe i took my GSXR in for it's service at a local Suzuki workshop and asked them to have a look for this headlight problem as it was not working at the time, 7 hours later and $200 bucks out of pocket... the shop still hadn't fixed and didn't know the problem :suicide:, so back home with a 2.5 ride and 1 hours daylight i managed such to scrape it in :eek:hmy! Once again thanks for the pic's champ, 15 minutes of work, and the bike is now working a treat!
 

·
Registered
Joined
·
3 Posts
Hey so I did this. Got my switch moving free again. Reassembled and the lights work great now. But the bike still won't start. Ignition fuse is good. 30amp starter fuse is good. Any other ideas?
 

·
Registered
Joined
·
246 Posts
Excellent write-up; my lights are working again, so this saved me a trip to the dealership. I just wanted to say thanks, Crush.

Did he skip the part about disconnecting the throttle cable(s), though, or did I just miss that part? I couldn't get the bottom half of the switch away from the clip-on with the throttle cables still attached. (Could be that I've got a K7 GSX-R and the write-up is for K5 GSX-Rs.)
 

·
Would come out of the closet - if I could find a s
Joined
·
4,077 Posts
Discussion Starter #32
Excellent write-up; my lights are working again, so this saved me a trip to the dealership. I just wanted to say thanks, Crush.

Did he skip the part about disconnecting the throttle cable(s), though, or did I just miss that part? I couldn't get the bottom half of the switch away from the clip-on with the throttle cables still attached. (Could be that I've got a K7 GSX-R and the write-up is for K5 GSX-Rs.)
Yeah might be different on a K7, but on my K5 I didnt have to disconnect it.

Glad the write up helped :cheers
 

·
Registered
Joined
·
4 Posts
:dunno Okay guys, im having this problem and began doing this! Waaaay too many little parts! Im not a gentle person and will forsure break it! How do i just bypass that stupid switch? I have a hid kit on any way. So its probably in best interest for the battery? Hook it up peeps!
 

·
Registered
Joined
·
1 Posts
Hey Crush, Just a note to say THANK YOU !! I had this exact problem, I was almost soaked by the local motorcycle mechanic until I came across your info, although my spring is melted to the plastic housing, I was able to bend the contacts up a bit and get me by until I get a new piece in. Awesome Pics Too, can't thank you enough, CHEERS!
 

·
Registered
Joined
·
4 Posts
Hey Crush, just sharing my thanks as well I replaced the whole switch last night from an extra control unit I had left over from my accident. I had been dealing with the light cutting out when I started my bike for a while and the mechanic had no clue other than buying another control unit. Great write up and pics allowed me to follow it through without issue.
 

·
Would come out of the closet - if I could find a s
Joined
·
4,077 Posts
Discussion Starter #36
Hey Crush, just sharing my thanks as well I replaced the whole switch last night from an extra control unit I had left over from my accident. I had been dealing with the light cutting out when I started my bike for a while and the mechanic had no clue other than buying another control unit. Great write up and pics allowed me to follow it through without issue.
good to hear :cheers
 

·
Registered
Joined
·
48 Posts
Is this also on the K4's too? Probably a stupid question but idk much. Not sure if they changed any electrical components between the K4s and K5s


Sent from my iPhone using MO Free
 

·
Registered
Joined
·
23 Posts
would this cause the fuel pump not to prime? my speedo is reading "chec" and will not go off. the manual said something to the account of it is a wire from the speedo to the ecm, or a side stand/ignition inter-lock system. im new sorry if this is a dumb question.
 
21 - 40 of 48 Posts
Top