Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 12 of 12 Posts

·
Registered
Joined
·
384 Posts
Discussion Starter · #1 ·
I was out riding yesterday and on two occasions where I wanted to use the horn, the horn didnt work. But later on it did work. I just kept pressing the button but never heard anything....


what could cause this?
 

·
Registered
Joined
·
115 Posts
i dont know, but mine has done it to me once already... its wierd
 

·
Registered
Joined
·
505 Posts
Re: sometimes my horn on my 05 600 doesnt work...what gives?

That happens to me almost everytime I ride my bike. I hear it's associated with the heat, most likely from the radiator. If you push the botton and feel the horn, you can feel it moving outwards as if it want's to honk, however it doesn't. I heard it's common on Suzuki's. I don't know what to do about it, though, my dealer out here said they almost all of them do it, and he'd replace it for me but he doubts that it will change anything. I am thinkin' about gettin' a cheap aftermarket 12v horn.
 

·
Registered
Joined
·
384 Posts
Discussion Starter · #4 ·
Re: sometimes my horn on my 05 600 doesnt work...what gives?

That happens to me almost everytime I ride my bike. I hear it's associated with the heat, most likely from the radiator. If you push the botton and feel the horn, you can feel it moving outwards as if it want's to honk, however it doesn't. I heard it's common on Suzuki's. I don't know what to do about it, though, my dealer out here said they almost all of them do it, and he'd replace it for me but he doubts that it will change anything. I am thinkin' about gettin' a cheap aftermarket 12v horn.


so I guess that the heat is affecting the wiring in the horn...interesting, but this is dangerous since I may need to use my horn in an emergency...


ohh how bout getting an air horn from pep boys/autozone?????
 

·
Registered
Joined
·
2,233 Posts
Re: sometimes my horn on my 05 600 doesnt work...what gives?

Pull in your clutch and rev up your RPM little.
I hardly ever use the horn. It seems I only use them by mistake.
 

·
Registered
Joined
·
8,423 Posts
Re: sometimes my horn on my 05 600 doesnt work...what gives?

Me too! Oops.....
 

·
Registered
Joined
·
231 Posts
Re: sometimes my horn on my 05 600 doesnt work...what gives?

+1 on hitting the horn on accident.
 

·
Registered
Joined
·
179 Posts
mine did the same thing on my 750 05. the dealer told me to take the horn off its one bolt. and there is an adjustment screw on the back of it turn it in or out till it works. i did it to mine and it works fine so far.
 

·
Registered
Joined
·
1,890 Posts
My horn did that for the first time this weekend on my K4750. As soon as I was done reading and catching up on post's, I was gonna start my own thread about it. Obviously no need to do that.

I will check out that adjustment.
 

·
Registered
Joined
·
1,149 Posts
Yeah that happened to me the other day. It was right after a wheelie that came down kinda hard. I tried using the horn and didn't work, so I thought I knocked something loose. Gusse it's happing to everyone eles. Oh-well I hardly ever use it anyway.
 

·
Registered
Joined
·
337 Posts
Yeah that happened to me the other day. It was right after a wheelie that came down kinda hard. I tried using the horn and didn't work, so I thought I knocked something loose. Gusse it's happing to everyone eles. Oh-well I hardly ever use it anyway.
That's funny shit !
I ride wheelies and sound the horn (more attention)
 

·
Registered
Joined
·
123 Posts
You are all forgetting one thing. While you may not use it in every day use, I can think of one time every year that you are gonna want to make it work for sure. Safety inspection time.
 
1 - 12 of 12 Posts
Top