Suzuki GSX-R Motorcycle Forums Gixxer.com banner

181 - 198 of 198 Posts

·
Registered
Joined
·
23 Posts
old thread, i know. but it's sticky...do i get a pass? :nerd:

K6 600 here, I have three relative questions,

1: How in the hell do I reach the TPS adjustment screw without removing the throttle body assembly? The screw is so close to the frame that I can't get my torx in there.
2: If the TB assembly does in fact have to be removed, do I adjust the TPS while running the engine?
3: Does the color of the wire in pin #30 vary per model of bike (600 750 1000)??? because I only have a K6 K7 750 service manual and it shows P/W (pink/white tracer) on the EWD??!!!
 

·
Registered
Joined
·
5 Posts
Re: SET Valve, TPS & herky jerky fixes. DIY

I just bought an 06 gsxr 600 the fi light is on I have put it in dealer mode and there is no codes. I get C00 with the dash at the top. My question is dose the set valve need adjusted or dose the TPS need adjusted to make the fi light go out.

Sent from my SM-G900P using Tapatalk
 

·
Premium Member
Joined
·
73,190 Posts
Re: SET Valve, TPS & herky jerky fixes. DIY

I just bought an 06 gsxr 600 the fi light is on I have put it in dealer mode and there is no codes. I get C00 with the dash at the top. My question is dose the set valve need adjusted or dose the TPS need adjusted to make the fi light go out.

Sent from my SM-G900P using Tapatalk
TPS. If it were the SET valve, you would see code c46.
 

·
Registered
Joined
·
23 Posts
Re: SET Valve, TPS & herky jerky fixes. DIY

I just bought an 06 gsxr 600 the fi light is on I have put it in dealer mode and there is no codes. I get C00 with the dash at the top. My question is dose the set valve need adjusted or dose the TPS need adjusted to make the fi light go out.

Sent from my SM-G900P using Tapatalk
Did you try putting in dealer mode then running the bike?
 

·
Registered
Joined
·
5 Posts
Re: SET Valve, TPS & herky jerky fixes. DIY

I figured it out today. The electronic motor was bad.

Sent from my SM-G900P using Tapatalk
 

·
Registered
Joined
·
190 Posts
So I am not sure if my bike has this problem or if it is just the nature of the beast.

My bike is smooth no herky jerky when just cruising steady RPM but say I let off the throttle the bike jerks like crazy and also when I roll back into the throttle it jerks, pretty much like an on off switch.

I have a hard time coming on and off the throttle smoothly no matter how slow or careful I am.

Some things to note about my bike.


I have removed the exhaust SET valve completley the cables and motor are gone with the wire pulled to eliminate the error code..

Also

The TPS always seems to stay in the middle position.
 

·
Premium Member
Joined
·
3,484 Posts
Probably the best fix for this issue is to flash the ECU with a bin-file that has deceleration fuel cutoff disabled. A friend's bike had really bad herky jerky throttle. After I flashed the ECU it was like a different bike, smooth throttle response and less engine braking.
 

·
Banned
Joined
·
3,858 Posts
So I am not sure if my bike has this problem or if it is just the nature of the beast.

My bike is smooth no herky jerky when just cruising steady RPM but say I let off the throttle the bike jerks like crazy and also when I roll back into the throttle it jerks, pretty much like an on off switch.

I have a hard time coming on and off the throttle smoothly no matter how slow or careful I am.

Some things to note about my bike.


I have removed the exhaust SET valve completley the cables and motor are gone with the wire pulled to eliminate the error code..

Also

The TPS always seems to stay in the middle position.
Check the TPS. Set it just above centre and see if it improves.

I've been riding my K1 around a bit today and its throttle response is amazing compared to the later bikes. The throttle response is instant and it's so smooth off the bottom.

I read somewhere the K1, K2 didn't have fuel cut on over run.
 

·
Registered
Joined
·
3 Posts
hey there im new to this site can anyone help me with some wiring trouble... where to plug in the ignition key barrel connectors two 4pin connectors one black one green and what is the grey 6pin connector under the air box.? any help would be appreciated
 

Attachments

·
Registered
Joined
·
32 Posts
Hey everyone! I was having the same issue with my bike. I just did this and I haven't received the FI light again yet. It's simple and takes 20 minutes. No jerky throttle!
 

·
Registered
Joined
·
2 Posts
Can someone explain to me about how to install the exhaust set valve I jus bought this k6 600 in alot of parts,I'm not sure what position the rear servo should be in?I think I'm out of whack when I turn key on it just clicks,But when I unhook the cables it spins freely,No noise it spins alittle one way then the other way.I really don't want to run with out it.Thanks I hope I explained this well enough.
 

·
Hand-Eye Coordinator
Joined
·
6,509 Posts
IF you bought the bike in parts, buy a manual.

Are you turning the key and letting the bike do a cycle through it's procedure? Putting the cables on backward would pull it the wrong way. Going back and forth once is the bike doing it's thing. Does it go back and forth?

Read the first few posts to see about just geting rid of it. It does nothing but satisfy emissions.
 

·
Registered
Joined
·
2 Posts
Mac I think that's my problem with the cables off if spins one way a second then the other way a few seconds.The cables were seized up I got them free,When I reinstall them It acts jammed up.I wasn't sure if there was a way to tell which cable goes where.Hate to buy a manual now seeing how this is my last part other than putting exhaust back on.I was just curious my 1st rodeo with one of these valves.Again thanks
 

·
Registered
Joined
·
15 Posts
I know this is an old thread but I just wanted to thank ZaXoS for the information he put out there.

Got mine working in less than 10 min, but I built a harness that goes inline with the actuator that allows me to run the motor in either direction with pair of push buttons and the volt meter has a pigtail that I can connect to. Makes it easier to get a reliable voltage reading from the actuator and I moving the cam position is much easier as well.

Thanks again to all that contributed.
 

·
Registered
Joined
·
137 Posts
I just picked up a k7 750 and this herky jerky throttle has completely killed that new bike experience, it is infuriating.. I honestly dont even want to ride the bike. I checked the tps in dealer mode and it looked like the tps had been adjusted to the top be previous owner, looks like he was experiencing the same thing and probably sold it for this BS reason.. Although i was reading to check in dealer mode with bike running as the line may be in a different place than when not running?
Also can anyone tell me if a flash and dyno tune has helped at all?
 
181 - 198 of 198 Posts
About this Discussion
197 Replies
109 Participants
MonkeyRider
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top