Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 12 of 12 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Morning all.

I'm having a really strange technical problem...

The engine is running super smooth on part throttle up to about 8000 rpm, after that it really bogs down (it does the same if I open the throttle right up) and I'm 99% sure the secondary injectors aren't firing.

The injectors are defiantly not faulty (I've tried them op a battery) and the fuel pressure is fine.

Has anyone experienced anything like this before and got any advice? I'm totally stuck!

Ben
 

·
Married his Fleshlight... And Also touches people
Joined
·
871 Posts
My 750 wouldn't rev past 8k when i bought it. It turns out one of the secondary injectors failed and wasn't opening but it was enough to severely effect performance.

Have you confirmed all the injectors are firing


Also perform a fuel flow test on the fuel pump to rule that out.

Sent from my SM-G900I using Tapatalk
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,713 Posts
The main filter in the pump is suspect. Do the flow test. Pray that you have a K7 or later.
 

·
Registered
Joined
·
5 Posts
Ok, maybe not the same but different if that make any sense, I was over at my tuning guys house helping him work on a home built long travel buggy that had a similar issue (08 GSX-R 1000 w/06 harness and ECU). If you revved it to 8 grand or so it would start to missfire and do all sorts of weird shit, we tried everything then totally by accident the cam sensor came unplugged while running it (on his chassis dyno) and it revved all the way to the rev limiter with no problems at all. He ended up putting a switch in the harness to cut the cam signal once it is running...

I had a similar problem on my race car Mini sprint w/08 GSX-R and cut down harness when my side stand switch messed up, car ran to 7 Gs no problem but no more then after trouble shooting for a day I found my side-stand switch was not working correctly and put a new one in and fixed!

I hope that sheds some light on new direction to go in when trouble shooting. Good luck!
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,713 Posts
Search for Fuel Discharge Amount Inspection in the service manual. The page varies depending on the year. Alternately you can leave the pressure gauge connected while you ride in conditions where it bogs down to check what the pressure is then. But that's generally complicated to hook up and dangerous to do.

The side-stand switch is another well known problem area but it's more associated with erratic operation instead of bogging down, i.e. it trips, oftentimes only briefly, the interlock relay. This cuts the power to the ECM, ignition coils, and fuel pump relay, which in turn cuts power to the injectors and fuel pump.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Thanks guys, tried all of the above and still doing it. I've put an AFR gauge on it too and it is definitely fuel, as soon as it reaches the point on the map where the 2nd injectors open it goes mega lean. Will be back in the garage tomorrow in search of a solution!
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,713 Posts
What rate did you measure during the flow test? You could try swapping the primary and secondary injectors but it seems a bit of a stretch that the secondaries are clogged while the primaries are OK. Make sure the fuel line isn't kinked. Are the secondaries getting power?
 

·
Dreaming of buttsecks for years...
Joined
·
13,421 Posts
I would assume if the secondary injectors had an electrical problem, the self-diagnostic would see it and give an FI code.
 

·
Registered
Joined
·
1 Posts
  1. Did you ever work out how too fix the problem? I have an 07 gsxr 1000 and the fault code is c37- secondary fuel injection. Any idea what actually causes them to not work?
 

·
Registered
Joined
·
4,880 Posts
Injectors can fail but best is to perform a true flow test. I've sent injectors our to perform a bench mark test but that was my personal pref as I didn't have a true setup to bench test them.
 
1 - 12 of 12 Posts
Top