Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 18 of 18 Posts

·
Registered
Joined
·
72 Posts
Discussion Starter · #1 ·
Any help there bobby, took the bike out today hit some twistys, and so forth, bike seems to lag some power on the low end, but at full twist the thing runs like a scalded dog. Just noticed that lower rpms is when it seems like it is missing or flooded, or something, and it will not do all the time, it isnt consistant. Was told it had a stage 3 in it when I bought it, and I talked to the mechanic that suppossed put it in. Is there any thing else that I might try, like advance the ignition, or something of that sort, tring to get some ideas.
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #2 ·
Also can you tell me if this sounds right, I went up 2 on rear, at about 75 mph bike turns about 6500 rpm, and also maybe it is weight but I thought by upping 2 teeth the thing should have pulled the front up in the air, but it will not, any other ideas
 

·
Registered
Joined
·
7,885 Posts
Speedy the only way I'd run a stage 3 kit is if the engine has been modded. Maybe try a stage 1 with an ignition advancer? I'm hitting 3400 rpms at 75 MPH on my 1100 so you are definitely within the powerband with 6500. What size bike are we talking about? how many cc's is your bike? These guys are heavy and it cost lots to even shave alittle poundage off them.
Bobbychet
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #4 ·
Bobby it is a 94 750, it originally had a Yosh header and pipe, and supposed Stage 3, have not confirmed yet, just hear say from ex mechanic
 

·
Registered
Joined
·
7,885 Posts
What kind of pipe are you running now? if no mods to motor I'd look into the rotor stator cover and see if it has a aftermarket one in there or it's still OEM. Factory still makes ingnition advancers for our bikes.What gear are you trying to get up on?
Bobbychet
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #6 ·
I have a D&D header and pipe on it, and when tring to pull it up I am in 1st gear, and just trying to roll the throttle within the powerband, and no go, and what about the stator
 

·
Registered
Joined
·
7,885 Posts
Try removing the stator cover and see if there's an aftermarket ignition advancer in there,if not you might want to get one. Sounds like a low end problem and this might help anyone else have input on this?
Bobbychet
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #9 ·
Not a hard thing to do but went out and removed the cover, still stock advancer, what to do, if I do put a advancer on it will it help, or do I have to pull the carbs back out.
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #10 ·
There is a artical on the forum put out by admin #142077 about making your own advancer, will this work for my bike?
 

·
Registered
Joined
·
149 Posts
Yeh I was wondering about whether mine was ever in danger of pointing skyward after a 44 was put on the back
but even if I nail it in 1st it only goes a little light on the front , mind you if I stick the ball and chain on the back it comes up a foot or more out fast corners (nice) but as they say these " W 's " are heavy on the front so I reckon the head stock would take a serious pounding if you got into flicking the clutch to often.
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #13 ·
Hey patto, your bike looks like mine, I try not to use the clutch cause it is stiff, I just put new springs in and carbon fiber clutch in, it is tight, was just wondering bobby is it possible to do what admin said, or do you even know.
 

·
Registered
Joined
·
72 Posts
Discussion Starter · #14 ·
Hey Bobby they quit handling Factory jet kits, and ignition advancers, will that work doing as the forum says, or where to go from here
 
1 - 18 of 18 Posts
Top