Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1 (Edited)
Hello all, this is AngryWasp reporting in. I just bought my first gsx-r 750 and sadly already ran into what could become a large issue with my motor. I was recently riding home from dinner, when my check oil light flashed, my engine dove into the lower rpms until it eventually shut off while in motion. :sad I am not sure if there is oil delivery issues with the oil pump in the 04 750 motor, or a sensor issue. So being new to this motor, I wanted to know if you guys on here know what could cause this, and if i need to worry about laying down the big bucks to repair it.

EDIT: It started right back up, and it ran perfect the rest of the way home.

Thanks for all imput and hope you all take me in as a fellow gixxer rider.:cheers

AngryWasp reporting in from the rocky mountains colorado.
 

·
Registered
Joined
·
17 Posts
I would imagine if it started right up and ran perfect afterwards, I would look more towards a pressure sensor... Usually if an oil pump goes bad, it just goes bad and that's it. My advice would be to find someone with a oil pressure test kit (sometimes auto parts stores rent specialty tools too), run it to operating temp, and verify proper oil pressure. Did it rattle/make any noises when the light came on? Hopefully that's all that it needs, Good Luck!
 

·
Registered
Joined
·
17 Posts
I'm admittedly pretty new to these bikes, but usually, when an engine looses oil pressure, they clatter like hell. Sounds more like a sensor malfunction to me, but I would def. test to be sure. Hopefully you got lucky!
 

·
Registered
Joined
·
85 Posts
Mine did this same thing when I bought it(k4 750). Matter of fact, when I took it for the first spin after I took it off the trailer, it shut off in the first 2 miles, little red light came on too. Pulled off the road and started it back up and made it home. It did this maybe 5 times over the next week and it has not done it since then. That was over 5 months ago and it has yet to do it again so I haven't changed anything.

I never noticed any increased noise or anything when it shut off though...
 

·
Registered
Joined
·
2 Posts
i have a 98 gsxr 600 that i just bought and mine is idling kind of high, and when i have it adjusted to where it is settling down, the red oil light comes on and it shuts off.. it starts right back up with a tiny tiny tweak of the throttle.... what is it suppose to idle at? right now if it goes below 2000 rpms the light will come on and not really stall out but more like just shut off... no weird noises nothing like that.. bike runs/ drives great, just after i come to a stop it will shut down when rpms get low...please helpp,, im going to change my oil, all pligs are new, no vacume leaks and carbs completely cleaned now... i dont think its been done for a while
 
1 - 7 of 7 Posts
Top