Suzuki GSX-R Motorcycle Forums banner

Problems with starter engine

738 Views 7 Replies 2 Participants Last post by  BillV
I've got a gsxr1000 k7 and since Monday it doesn't work. When you push the start bottom you can listen the starter relay but nothing happens. I took it out and it works when you connect to a 12v. But when I put it on my bike it doesn't work. I have charged the battery and I have checked the starter relay, sometimes it gives 12v and sometimes it gives 4 or 6v. Do you think that the problem is that relay?? Once the bike give an _C40 error, but only once and I don't know if it is because of this problem
1 - 4 of 8 Posts
"I have checked the starter relay, sometimes it gives 12v and sometimes it gives 4 or 6v"
What are you checking? The red cable from the battery should always be 12 V while the black cable to the starter should be 0 V except when cranking, when it should be around 11 V. You have a bad electrical contact if otherwise. The Y/G to the solenoid coil should be 0 V when not cranking and 12 V when the start button is pressed. The B/G lead from the solenoid to the clutch switch should be 0 V when not cranking and 0 V or 12 V when the start button is pressed, depending on whether the clutch lever is pulled or not.
Today I have tried to connect the starter motor directly to the battery and it doesn't work but if i take the starter motor out and I connect to 12v , it works. I don't know if the problem is the starter motor or if I have any other problem (sorry for my English)
Measure the voltage at the starter's cable connection when you press Start.
12v 🤷‍♂️
The ground cable connects to the crankcase near the starter and to the battery on the other end. Check both ends for tightness. Will the bike push start?
I've checked the ground cable. In the battery it's ok, and in the crankcase it seems to be ok, I tried to take it out to clean the connection but it's so hard. Do you think it could be a good idea trying to clean this connection? When I turn the bike on, it checks everything, the fuel pump works, the problem is when I push the start bottom, I can hear the start relay but nothing happen. Thanks and sorry for my english
1 - 4 of 8 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.