Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
hi everyone, newbie to the forum so not sure if im posting in right forum topic.

I have a gsxr 750 k5 with 6900 miles on the clock.

it has a yoshimura tri oval can, and a power commander both professionaly installed and set up on a dyno, at an approved dynojet centre.


was out on the bike yesterday cruising at around 50 mph, i went to roll on the throttle (not yanked on just gently opened) , and the bike went haywire on me, very jerky (almost like something was blocked, or was being starved of air/petrol)

the engine didnt stop/stall, but the red oil light began to flash and the fi warning came up.


so, i pulled over, turned the bike off and checked oil level etc, no leaks and everything fine there.

so i started it up again (no warning or fi lights showing) and carried on my ride (i had to get home) , i tried to roll on the throttle again this time i was only doing 40mph, and the bike did exactly the same thing.

from what i can remember i was only low in the revs, cant remember what gear i was in.


any help greatly appreciated. this bike has been regualrly serviced and has just had brand new oil in.
 

·
Registered
Joined
·
2 Posts
ive had a jerky throttle issue over 8k rpm, the problem was in the quality of petrol, secondary injectors didnt work well, but the FI light didnt show up for me...
there are several things that could be the problem here

quality of the petrol *(does not explain FI light tho)
secondary injectors (highly unlikley since they kick in mid+ rpms)
sparkplug issue (sounds reasonable here)

if you get FI light again put the bike in a dealer mode.
 
1 - 2 of 2 Posts
Top