Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Ok so first post ever lol. Two days ago I was on my way home when I stopped to fuel up. After I put the gas in and started I had zero acceleration. 45 mph for about 3 miles. When I got home I dumped the gas ran the bike until completely empty (about 3-5 minutes) put new spark plugs in refueled the bike and still having the same problems. Bike starts just fine even after a full day of sitting. Go out today and started up just fine idle just fine but as I attempt to drive up the street and back same issue. Rpm will not go over 4K. What do you think the problem is.
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,637 Posts
Clogged main fuel filter. Run the fuel flow test.

Also check that the fuel line isn't kinked. But that's not going to happen by adding gas.
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,637 Posts
The lower filter (strainer) is cleanable. I'm inclined to say that the upper (main) filter can only be temporarily cleaned but others claim otherwise. But you really ought to first figure out if the pump is the problem and that's what the flow test is about.

P.S. What year?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
It’s a 03. So I removed the fuel pump. And replaced seals and filter and placed it back. Put about a gallon and a half and still had the same problem at 4K rpm. Should I check the injectors
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,637 Posts
Do the flow test.

"And replaced seals and filter and placed it back."
Sounds like you only replaced the strainer. You won't like the price of a new main filter.
 

·
Registered
Joined
·
285 Posts
+1 ^ do the flow test. Low flow can cause this issue. Do not confuse pressure with flow. Even with good pressure, flow volume can still be low...
 
1 - 7 of 7 Posts
Top