Suzuki GSX-R Motorcycle Forums banner
1 - 1 of 1 Posts

· Registered
1 Posts
Discussion Starter · #1 ·
Hello, I have a working bike with pc3, ignition module and dynojet quickshifter. Suzuki gsx r 1000 k5. Ignition module is connected to the pc3. Quickshifter is connected to the ignition module.
2 weeks ago i updated the pc3 to the 2.3.2 version and all went ok. The ignition module instead is at 2.0.1 and it needs to be flashed to the new version but right now I don't have a programmer.
After the firmware upgrade all worked like before.
Some days ago i noticed the quickshifter wasn't working anymore, I could't shift only with the left pedal without the clutch.
I thought that the qs could have died so i tried to use a voltimeter and check for continuity pushing manually the quickshifter. It seemed to work.
So right know i don't know if i have to update the firmware on the ignition module to have the qs working again. Another thing i noticed, in the power commander software the option to configure the quickshifter has disappeared. What do you think? A faulty module or do I need to flash the newer firmware on the ignition module? What is really strange is that until some days ago the qs was working even if the pc3 version was 2.3.2 and ignition module 2.0.1. Thanks
1 - 1 of 1 Posts
This is an older thread, you may not receive a response, and could be reviving an old thread. Please consider creating a new thread.