Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 7 of 7 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Going real fast on 07 600.smell eggs. Got off highway bike drove 2 min then power off everything. No start. I lift seat. Battery smoking. Ignition fuse blowout. I put new batt, new fuse. No start. Only backlight on dash is on and neutral light. I changed stator, regulator, fuses,relay,battery,fuel pump, fuel pump connector was fried. Still just crank, no start, no dash, can someone guide me.
 

·
Registered
Joined
·
3,585 Posts
Follow the power. Get a voltmeter and trace from the battery as far as you can go. I would also look at all.the fuses and connectors as well before going much further just to eyeball there condition.
I would yank off every bit of plastic and really look at what you got especially if it melted the fuel pump connector.
 

·
You should listen to me. No, seriously, listen to
Joined
·
10,751 Posts
You're running blind without the manual. It will provide information on the fuel pump relay, which needs to be checked both for power to it and for a control signal from the ECM. The ECM might not be getting power, which can be checked with a multimeter, or it might be fried.
 

·
Registered
Joined
·
3,585 Posts
Set the meter to the dc scale and start at the battery and follow the power wires. Keep checking for 12v and inspecting everything along the way.
It's very possible you fried your computer but I wouldn't go buying one yet even though you seem to be buying everything else already. It's much harder to track down the problem if things keep getting replaced without testing.

When you say no dash are you now not getting any lights on it now?
 
1 - 7 of 7 Posts
Top