Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
28 Posts
Discussion Starter #1
Hi all got a 1988 750 slingshot that I recently bought

as the title states it has no N light and no spark but does crank freely.

checked fuses and no issue.

where do I begin troubleshooting ? The N light or lack of may be part of the issue I guess

many thanks
 

·
Likes to race old junk.
Joined
·
2,161 Posts
Are the other dash lights on?...like the speedo & tach back lights and the oil pressure light.

Without knowing the bike's history, I'd be hesitant to include the neutral light in my troubleshooting, if I didn't know if it worked to start with.
 

·
Registered
Joined
·
28 Posts
Discussion Starter #3
Are the other dash lights on?...like the speedo & tach back lights and the oil pressure light.

Without knowing the bike's history, I'd be hesitant to include the neutral light in my troubleshooting, if I didn't know if it worked to start with.
ill have to strip the fairings off to get any deeper in to the electrics. The oil light comes on - didn’t check anything else yet.

I found the diode for the side stand removed and as it’s in the same circuit as the N light - must mean something.

the person I bought it off said it needs a CDI but he is not a bike tech and said he had someone check it out.

I want to eliminate the side stand / diode / N light circuit as I see signs of intervention there already
 

·
Registered
Joined
·
28 Posts
Discussion Starter #5
Yes got the diagram thanks, I guess I'll get the multimeter out and start checking.
How does one diagnose a faulty CDI ?
 

·
Registered
Joined
·
174 Posts
I don't have this particular bike, so I can only go by the wiring diagrams. I would try to eliminate everything before the CDI.
You said bike cranks but no spark. There was no spark at the plugs? (NB. Plugs have to be grounded when testing for spark).

Check to see that you have 12v at the coils. Red probe to O/W wire, Black probe to Batt -ve. (Ignition switch On, Kills switch On, Side stand in Up position).
 

·
Registered
Joined
·
28 Posts
Discussion Starter #7
I don't have this particular bike, so I can only go by the wiring diagrams. I would try to eliminate everything before the CDI.
You said bike cranks but no spark. There was no spark at the plugs? (NB. Plugs have to be grounded when testing for spark).

Check to see that you have 12v at the coils. Red probe to O/W wire, Black probe to Batt -ve. (Ignition switch On, Kills switch On, Side stand in Up position).
Thanks for the reply, I think the lack of N light might be part of the problem so going to start there and try to find out why its not coming on.
Will check continuity accross side stand switch, N switch, check N light bulb etc.

While there will also check for 12V at coils of course.
 
1 - 7 of 7 Posts
Top