Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 9 of 9 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
My bike started to take longer than usual to start when its cold so i thought to change the spark plugs after changing them the bikr rattles and rpm breaks a little bit between rpm's 2 nd 4 only then its okay as if its running on 3 spark plugs only but i checked and all 4 are operating i really dunno what to do
 

·
Captain Obvious ... because obviously it’s obvious
Joined
·
3,843 Posts
Well, it should start instantly, so you might want to check the fuel pump with the fuel flow test. And check for FI codes. Also, you need to check that everything is plugged in and that your spark plugs are tight.
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,580 Posts
Did you reconnect all the hoses, in particular the IAP sensor? Might your ISC valve need cleaning? Is the throttle position sensor properly adjusted?
 

·
Registered
Joined
·
13 Posts
Check your fuses there could be a dirty connection and check all wires and leads below tantalising something isn't connecting right I think

Sent from my SM-G935F using Tapatalk
 

·
Registered
Joined
·
258 Posts
Definitely double check yourself. If this problem didn't start till after you played with it then something is off

Sent from my SM-G920V using Tapatalk
 
1 - 9 of 9 Posts
About this Discussion
8 Replies
6 Participants
GunMetal81
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top