Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 10 of 10 Posts

·
Registered
Joined
·
45 Posts
Discussion Starter · #1 ·
Been chasing this problem around for awhile. 20k mi. 05 GSXR 600. Problem started about 6 months ago, and progressively getting worse. After the bike is warmed up there is a sputter at idle, but its not consistent. Feels like a cylinder is misfiring or fuel is off or something. The whole throttle body has been changed (Fuel rail, injectors, STVA, TPS, etc) and had zero effect on the problem. Battery has been changed and tested, no effect. Plugs have been changed, no effect. Air filter has been changed, no effect. Any idea where to go next? Was going to get new wires for the spark plugs next.
 

·
Lets go racing!
Joined
·
7,568 Posts
I had a similar issue, my stock 600 headers and d&d pipe were crap, my idle was never stable, after I put on my 1k headers the idle problem was fixed, no more rough idle, it was just smooth and stable. What is your idle speed set at?
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #3 ·
Wanna say its around 1400-1500 at temp. Has Muzzy slip on and K&N are only aftermarket parts.
 

·
Registered
Joined
·
3,068 Posts
Muzzy slip on or just a can? +1 on pc3 I got one after installing an Akra full system and it made a noticible difference all around.
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #6 ·
Muzzy bolt on.. just the muffler.. has stock headers on it. Also just for reference, the problem started prior to the exhaust installation.
 

·
Registered
Joined
·
379 Posts
do you have this problem when riding or just sitting at idle?? i would check spark first. maybe you have an intermittent problem with one of the coils??
 

·
Registered
Joined
·
45 Posts
Discussion Starter · #10 ·
Only at idle.. never noticed it while going down the road.
 
1 - 10 of 10 Posts
Top