Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 4 of 4 Posts

·
Registered
Joined
·
31 Posts
Discussion Starter #1
K5 600.... I have led turn signals and the other day I believe a resistor for the signal completely burnt up and then one wire broke off of it causing my speedo and headlight to malfunction and not respond. I have a led fuse to stop hyper-blinking, so my question is this, Do I need to replace the resistor or will the LED fuse be enough and should I just connect the wires without the resistor?
 

·
Hand-Eye Coordinator
Joined
·
6,509 Posts
You need to buy a multimeter and start testing more than just the blinker. The info you have now is near worthless.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #3
So the headlight and instrument panel aren't working except for neutral light. Apparently, from what I've read, there is a wire in the main harness that has a short or the connecters somehow got a short, haven't had time to check it but on my day off I'm going to give it the old college try.
 

·
Registered
Joined
·
31 Posts
Discussion Starter #4
So this is what was wrong with my bike. I don't know why this thing overheated and melted but thats what it was. I did exactly what the guy said to do in the video and it started working, only problem now is my speedometer is stuck on 0. will update soon!

 
1 - 4 of 4 Posts
About this Discussion
3 Replies
2 Participants
Bowsersgsxr600
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top