Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 18 of 18 Posts

·
Premium Member
Joined
·
243 Posts
Discussion Starter · #1 ·
I am having trouble launching, i tired giving it a little rpms and slipping the clutch but I either bogged or stalled, I found my best 60ft was when I just took off like I was at a stoplight, and quickly into full throttle. But this was still a 2.4 60ft! I need to get them down to atleast a 1.9.

Thanks,
 

·
Registered
Joined
·
474 Posts
I'm still trying to master the launch. Last week I was doing what you did. Leave the line and roll on the throttle as quick as possible without lifting the front. I was consistantly pulling 2.0x short times. After some coaching from others, I now rev to 5000 rpm and slip the clutch leaving the line and keep adding throttle as you let out the clutch slowly. I'm now getting consistant 1.8x 60' times. I know that I can get that better. BTW: I have the bike strapped and the rest is stock.
 

·
Registered
Joined
·
174 Posts
I was getting 1.8x 60' times on a stock suspension (no strap yet) by holding the throttle to about 4k with the clutch pulled in just enough so I can hold the bike back with my toes on the ground. I then modulated the clutch and throttle, in an effort to maintain 4k rpm's until my bike caught up. This way the front wheel stayed on the ground until I was done with the clutch. I did get a 1.7x 60' time by being alot more aggressive with the throttle, but I left the line on a wheelie, and it was one of my slowest runs.
 

·
Registered
Joined
·
125 Posts
I was getting 1.8x 60' times on a stock suspension (no strap yet) by holding the throttle to about 4k with the clutch pulled in just enough so I can hold the bike back with my toes on the ground. I then modulated the clutch and throttle, in an effort to maintain 4k rpm's until my bike caught up. This way the front wheel stayed on the ground until I was done with the clutch. I did get a 1.7x 60' time by being alot more aggressive with the throttle, but I left the line on a wheelie, and it was one of my slowest runs.
1.8 60' and you ran a 10.06 thats a little hard to do.... or for me it is, cause i was running 10.20 with a 1.65, 1.7 60'. But im new to the drag racing scene.
 

·
Registered
Joined
·
242 Posts
i run consistant 1.7 to 1.8 60' with 10.1 - 10.3 at 139 to 141 . i leave at about 5,500 rpm with no burnout or lowering or any of that good stuff. i know it gets better because i hardley wheelie off the line. rear spins just enough to keep me moving down the 1/4.
 

·
Registered
Joined
·
6 Posts
hey if u guys are worried about the front wheel coming up slam the fuck out of it and throw some straps on the front and launch like a mother fucker. I know it helped for me but the thing is i have an 04 600 but it came up before i stapped it and lowered it. To be honest im running a 10.7 in a 1/4 but thats after some mods ive had done.
 

·
Registered
Joined
·
174 Posts
hey if u guys are worried about the front wheel coming up slam the fuck out of it and throw some straps on the front and launch like a mother fucker. I know it helped for me but the thing is i have an 04 600 but it came up before i stapped it and lowered it. To be honest im running a 10.7 in a 1/4 but thats after some mods ive had done.
Yeah, that worked on my 750, however I really doubt the same tricks will work on this bike simply because there is a power difference of 30+ HP from the 750, 50+ from the 600.

That and the fact that I have seen '04 1000's lowered and strapped, and they have almost as much trouble launching as I do. It will help I am sure, but I don't think it is a straight-up fix like it is on the 600/750's.
 

·
Premium Member
Joined
·
243 Posts
Discussion Starter · #8 ·
round 2 for me friday....well see if i do any better.
 

·
Premium Member
Joined
·
993 Posts
With those 60's and 1/8 times you are running where is the top end ... seems low . Here are a couple slips from my 01

Dave
 

·
Registered
Joined
·
28 Posts
my bike is bone stock and im only running 10.30's with a 60 ft time of around 1.8 1.9 and Im leaveing around 5 to 7 thousand rpms at our track its not the best for tracktion I know i can go faster but cant hook up I lowered my rear tire pressure to 13 lbs and I still spun but got tracktion sooner then right into a wheelie so couldnt keep up the hard acceleration Im going to lower it for my net trip
 

·
Registered
Joined
·
4 Posts
ive only had my Stock K4 thousand out at the drags twice now. I too have a big problem launching! Constant low 2.0's. With a best of 1.920 Managed to run a best of 10.59 @ 139mph. With a 60ft of 2.002. So i know with a decent launch the bike is more then capable of a low 10! Just a matter of getting over the initial nerves i guess..
 

·
Registered
Joined
·
242 Posts
ive only had my Stock K4 thousand out at the drags twice now. I too have a big problem launching! Constant low 2.0's. With a best of 1.920 Managed to run a best of 10.59 @ 139mph. With a 60ft of 2.002. So i know with a decent launch the bike is more then capable of a low 10! Just a matter of getting over the initial nerves i guess..
look at your rpms you are leaving the line at and then increase it by about 500 - 100 each time until you are where you want to be.
 
1 - 18 of 18 Posts
Top