Suzuki GSX-R Motorcycle Forums Gixxer.com banner

Status
Not open for further replies.
1 - 2 of 2 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
Hey all I'm new to the forum and to owning a zuk street bike but anyways I've got a L6 gsxr750 with 1780 miles on it and picked up the bike recently from a friend that literally had it sitting around. Now I know he rode it from time to time the bike sat a ton. Either way I get the bike home and started it up and let it warm to operating temp and all was good, didn't get to ride because it has rained buckets this summer. Got some good weather the other day and got out for a bit and pretty much as soon as I got on the service road(ten houses away) I could tell the bike was hesitating to accelerate smoothly. Totally noticed the gas was bad upon inspection so I drained the entire tank and put fresh 93 in but to no avail, I've put around 50 miles on her since fresh fill and the bike stumbles horribly from idle to around 2500-3000rpm. Above that is ok but I can still feel a slight surge. Pretty inclined so I've checked the obvious spark plugs look great, intake clean, throttle bodies spotless, haven't messed with injectors or cleaners to this point but all looks like a brand new bike. I've read a bunch of places the k series had some issues with the ics and possibly the tps but not much info on the L series bikes. Clogged injectors or what? Battery prob went stone dead a few times also since it sat so much. No fi light either. Any info would be great thank you.
 
1 - 2 of 2 Posts
Status
Not open for further replies.
About this Discussion
1 Reply
2 Participants
8you4t
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top