Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
Hello .
Im having a problem with my L1.
I have installed a PC5, removed the cat, changed airfilter to a k&n and mounted a single yoshimura slipon.

I downloaded a map from dynojets website and the bike ran very smooth.
After i have tuned it in a dynojet bench the bike doesnt run smooth at all from
3000 to approx 4200 rpm.
If i use constant or very slowly increasing throttle between this rpm the bike starts to behave very "jumpy"( dont know the English word for it)
First i thought it was the maps fault so i have tested 3 different maps including a zero map with the same result.
Im really stuck now, i dont now what the problem might be.
Any suggestions of what might cause my problem?

Drive safe/Micke from sweden
 

·
Registered
Joined
·
18 Posts
Hi, mine was the same , I fitted single akrapovic , k&n filter , pc5 , then had it dynojet tuned , and ran shocking , took it back to shop , they said it has been tuned up correctly and is producing 11bhp extra , they told me it may be a pc5 fault , so I returned it to dynojet uk to be tested , and they said it is fine , and it may be a fault of my bike , yet when I removed pc5 from my bike , it runs fine , although tick over is a little jumpy , but I think this is due to k&n , and exhaust change, and I can live with that , my advice is get rid of pc5 , it cost me 279 + 160 for tune , + stress , if u dont race u wont need any extra power .
 
1 - 3 of 3 Posts
Top