Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 20 of 24 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Hey guys, after winter my bike is not running properly. Bike won't idle (dies if not using throttle), revs quite poorly and has a sound of diesel engine.

I have changed the plugs and checked the timing. Exhaust heads will heat up and engine will fire up instantly if applying throttle at the same time.

Any advice what to check next? Thanks!
 

·
Currently using pedals..
Joined
·
2,979 Posts
First, please go introduce your self in the "Starting Line" section and tell us about yourself!

Some things that come to mind are fuel injectors and the fuel pump. Since it is somewhat running, you could try to run some seafoam through it and see if that helps clear it up if the injectors are gunked up :dunno
 

·
Captain Obvious ... because obviously it’s obvious
Joined
·
3,844 Posts
Did you look to see if your fuel tank rusted?
 

·
That’s Mister Chalet To You ....
Joined
·
7,744 Posts
When I hear "diesel engine", that suggest knocking like a blown connecting rod but I'm more inclined to believe you're running on 3 cylinders, which makes the bike sound like shit and do everything you're describing. If you've changed the plugs, possibly a coil went south.

Very easy to check - when you say exhaust heats-up, did you check all 4? Rather than running it like that, I'd pull the plugs and just check each for spark.


Pull out your phone and record a quick video.
 

·
I know things... A lot of things.
Joined
·
3,101 Posts
Do you see FI flashing on the dash? Also, how does the engine perform under load? Can you ride the bike and if so, does the engine operate better or worse at larger throttle openings?
 

·
Hand-Eye Coordinator
Joined
·
6,509 Posts
This issue is not mechanical. I would bet tree fiddy that you didn't use a battery tender during storage, right? Test your battery voltage. These bikes run basically on battery power when at idle.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #9
I will do those things tomorrow. All 4 heads were warming up instantly (but sounds like running on 3 cylinders). When giving throttle engine is working better after some jerkiness but you have to give some throttle constantly. I charged the battery couple of times but i will check it also.
 

·
Registered
Joined
·
286 Posts
Start with vacuum lines, diconnect from Manifold Air Pressure sensor and blow into them, if You feel resistance there's water/residue in those lines and your MAP sensor tells rubbish to the CPU and it does not run the engine right... the proper blow through may clear them and the bike will start normal however You still need to clean them or replace them (don't go for original ones if You do, they're bloody expensive...) :)
 

·
Premium Member
Joined
·
3,486 Posts
Start with vacuum lines, diconnect from Manifold Air Pressure sensor and blow into them, if You feel resistance there's water/residue in those lines and your MAP sensor tells rubbish to the CPU and it does not run the engine right... the proper blow through may clear them and the bike will start normal however You still need to clean them or replace them (don't go for original ones if You do, they're bloody expensive...) :)
I would also start with these. Try disconnecting the IAP sensor's connector first. If bike runs better, then the vacuum lines are clogged.
 

·
I know things... A lot of things.
Joined
·
3,101 Posts
+1 on the vacuum lines if the motor runs better with more throttle. You can probably test them by seeing if running with the IAPS disconnected makes the problem go away, or otherwise significantly changes engine operation.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #14
There was also short hizzing (pressure release) sound which can be seen at the beginning of the video.
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,584 Posts
Disconnect the xtre for now. What is the idle speed once warmed up? I guess the answer is 0 RPM if it won't idle but it should try to idle at some RPM before dying. Have you been fiddling with either the idle or fast idle screws or the TP sensor mounting screw? Can you see the secondary throttle and, more significantly, the cam on the end of the secondary throttle shaft move to the fast idle position when you turn the ignition on to start it? You should also be able to see the cam rotate to the normal position after running for 30 seconds or so. The bike should idle at 1200 RPM (by the tach) and the TP sensor should be set to the middle position per 4-20 of the service manual. I don't hear either a diesel sound or a "hizzing" sound in your video. The gas cap will make a sound shortly after a ride that I think is the vent operating (mine is an E33, don't know if other models do this).
 

·
Uses squid tentacles as a butt-plug
Joined
·
262 Posts
Disconnect the xtre for now. What is the idle speed once warmed up? Have you been fiddling with either the idle or fast idle screws? Can you see the secondary throttle and, more significantly, the cam on the end of the secondary throttle shaft move to the fast idle position when you turn the ignition on to start it. You should also be able to see the cam rotate to the normal position after running for 30 seconds or so. The bike should idle at 1200 RPM (by the tach) and the TP sensor should be set to the middle position per 4-20 of the service manual. I don't hear either a diesel sound or a "hizzing" sound in your video. The gas cap will make a sound shortly after a ride that I think is the vent operating (mine is an E33, don't know if other models do this).
Yes ALL models should vent and make that sound I was quite confused my first time as well then realized it was coming from my cap.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #19
IAPS was disconnected on that video. Throttle valves move as they should be and i adjusted TP sensor last year.
 

·
Registered
Joined
·
286 Posts
You mean Manifold Air Pressure Sensor connecting to vacuum lines not the one under the seat which is Atmospheric Air Pressure Sensor... right? And You removed the little rubber hose off it Correct?...
 
1 - 20 of 24 Posts
About this Discussion
23 Replies
11 Participants
jamuha
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top