Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I just bought a 2002 GSXR 750 the high beam works, no low beam. Brand new LED bulbs. Does any one know if they work off of the same relay or different relay? Where are headlight relay(s) located?


Thanks
 

·
Not the powers that be, not even close.
Joined
·
23,135 Posts
 

·
Not the powers that be, not even close.
Joined
·
23,135 Posts
I'm assuming a 2002 GSX-R 750 for the US and Canada? Check the fuse #2 headlight low. If the fuse is good check for 12v from the white to black wires in the connector. I can't see the polarity being backwards if both the high beams are working. They are H4 style bulbs?

 

·
Registered
Joined
·
2 Posts
Discussion Starter · #4 ·
I'm assuming a 2002 GSX-R 750 for the US and Canada? Check the fuse #2 headlight low. If the fuse is good check for 12v from the white to black wires in the connector. I can't see the polarity being backwards if both the high beams are working. They are H4 style bulbs?

It's US. I've taken apart the switch and cleaned it. Yes, they're H4 bulbs. I've seen online that some bikes have a relay(s) that control high & low beam. Just don't know where it's located.
 

·
You should listen to me. No, seriously, listen to
Joined
·
9,686 Posts
There's no relay on the 1000 so I'm doubtful of one on the 750. A common issue is failed contacts in the connector between the main and front harnesses.
 
1 - 5 of 5 Posts
Top