Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 7 of 7 Posts

·
Registered
Joined
·
25 Posts
Discussion Starter #1
Hi there
I have recently purchased a 2010 gsxr1000 the second night riding it the bike cut out when high in the revs which wasn't much fun.

Yesterday while riding the bike done it again a couple of times nearly causing me to crash.

No lights come on

Bike has single slip on yoshi
10000 ks
Side stand switch has been done and is still tight with both bolts in.

Any ideas
 

·
Registered
Joined
·
327 Posts
Check the plunger on the kickstand switch even if the bolts are still tight. I zip tied mine closed and covered in electrical tape and no problems since. I had the same issue and this solved it.

Otherwise check battery connections, clutch switch etc.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #4
Thanks guys

Was going to try bypassing the side stand switch and see how that goes

checked the batter all good
 

·
Registered
Joined
·
25 Posts
Discussion Starter #5
Guys it would seem it's the side stand switch

I bypassed it 3 days ago and have been on 2 rides and it has not missed a beat.

Previous to this it has played up each time I had ridden it.
 

·
Registered
Joined
·
25 Posts
Discussion Starter #7
Thanks for your help guys

I have done over 1000k's now without a problem gunna put a new switch in this week.

I wasn't going to worry about it until last night a mate turned my bike and and went to start it while in gear on the stand I was lucky I caught the bike as it was on its way down :)
 
1 - 7 of 7 Posts
Top