Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 20 of 20 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
Bike is a 2007 gsxr 600, all stock. Sat for alittle while before I bought it.
Has new battery,fuel pump

bike starts up but then dies right after, I can keep starting it and notice once it gets warmer, it starts to idle ok, but when I turn throttle it stumbles/missing and won’t go past 4k easily. And if I full throttle it while at idle it really misses and has a bit of lag. As well as when I hit my turn signal the rpm gauge goes to zero then back where it was. Tail light is dimming. And when I’m riding it it starts out slow and then kinda stumbles and the gauge cluster will act funny, as in my rpm will go to zero and my gas light will start blinking as well as it will say I’m in the wrong gear(I’ll be in first and it thinks I’m in second or third gear on the indicator.

the rectifier is in the oem spot and am planning to move it but when I rode down the street then touched the rectifier, it was pretty damn hot. Just wanting to know what this is. I did put some fuel cleaner in as well. But I’m stumped
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #3 ·
I had my battery tested, 12.69 volts and then had it under load and said 350cca surprisingly
 

·
Likes to race old junk.
Joined
·
2,402 Posts
You have asked for help...I'm trying to determine the health of your charging system.
Once again, what is your battery voltage at idle? and at @5000rpm?
Do you have a multi-meter? A cheap $20 one will be fine for what we're trying to determine.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 ·
I’m getting 12.8-12.9 with nothing on then with everything started and bike running and brights on it slowly jumped up to 14.2 at idle in about 20 seconds
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #8 · (Edited)
So I read the trouble shooting steps, it says to test the battery voltage. But it showed ok voltage right? It then said if yes then faulty battery or abnormal driving condition
 

·
Premium Member
Joined
·
764 Posts
Ok, you say the Charging systems checks out, go to next step, Current Leakage, it sounds like a short circuit somewhere, test each system in the manual.
Gear Position Switch is not right, test it. Study the Wiring Diagram and learn every circuit. You will find the problem.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
So it seems like the gauge cluster is working correctly but I’m still having trouble starting the bike over and having it idle. Doesn’t seem to want to idle until around 100f then it starts to idle ok but then I take the bike around the block and it stumbles in low rpm and when I rev it I wants to not go over 4k rpm but when it hits that it sounds bad but then later on it will rev all the way up. And when riding it will stumble until 4k then give a jolt of power all the way until about 8-9k rpm
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #12 ·
There was a killswitch that the previous owner had going to the ignition wire (orange) under the seat. I removed the killswitch wires and spliced the ignition wires back together and it just seem to make the rpm go to zero with the turn signal turned on like before. But still having this bad idle/ miss/ stumble while riding issue.
 

·
Premium Member
Joined
·
764 Posts
Ok now you have fixed the electrical problem. This could be fuel system, what does your tank look like, clean ? Check fuel pump pickup screen.
Do a fuel flow test as in the Workshop Manual.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #14 ·
Well when I got it, the bike sat for awhile so I poured a whole bottle of fuel system cleaning in the tank along with like 3 gallons. That’s when I started having issues
 

·
Dreaming of buttsecks for years...
Joined
·
14,444 Posts
So, drain it and put fresh gas in. A whole bottle usually treats 20-25 gallons, not 3. Read the fucking label next time.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #17 · (Edited)
Yea you are right, I know. I mean the bottle says treats up to 20-25 gal. So I thought just put the whole bottle in. But yea I’ll try draining it and pour fresh fuel in, and report back. Thanks

I will says this is as well though, when I start thebike and it’s idling, when I blip the throttle I hear a whoosh sound of air and that’s when it wants to die then I do it again and the same whoosh sound of air again. Almost sounds like a cold air intake on a car when they rev the motor up. Anyone know what that sound is?
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #19 ·
So too much air and not enough fuel(due to clog) is why it doesn’t want to start but then does and has trouble at idle and in the rpm range?
 

·
Premium Member
Joined
·
764 Posts
If I didn't know better, I would think you were just adding comments here, just for a laugh. 😆 Your comments sound like you are off your rocker, But I don't mind, It's entertaining me. 🤣..... (derogatory comment, that I will keep to myself ) 😂
 
1 - 20 of 20 Posts
Top