Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 11 of 11 Posts

·
Registered
Joined
·
13 Posts
Discussion Starter #1
Hey guys, new owner of a used K6 600. I searched and read many of the results but I'm struggling to find a solid answer. I've learned from many of the posts I've read that the waterpump leaking oil / coolant is very common due to the O rings or mechanical ring , etc. Which makes me thing this is the issue I have. HOWEVER, after taking the farings off, I have now found oil in other questionable parts that make me wonder if there is an additional oil leak elsewhere or if it could be oil from the waterpump that has made it's way there. (See pictures attached) .

I did a fresh oil change after I got the bike 1 month ago, so the oil I'm finding in some areas is nice and clean, however, the oil I see in the back of the waterpump is very dark and cooked.

Any help is much appreciated.

leak1.jpg


leak2.jpg


leak3.jpg

leak4.jpg
 

·
Registered
Joined
·
13 Posts
Discussion Starter #3
Wash the bike.......Then find the oil leak.
thanks brother, I'm in the process of cleaning everything I can right now. any other thoughts or ideas let me know. I read somewhere that I could add a UV additive which I think is a pretty clever idea. I might go that route if I can't easily find the source.

Temperatures have also dropped a lot here, and my garage is not insulated so I'm wondering if condensation or moisture has a play in this too. I'll update after I've cleaned everything off.
 

·
Registered
Joined
·
2,904 Posts
You can usually find a tricky leak.......after cleaning well, but you can then dust the areas in question with talcum powder, or similar.
 

·
Registered
Joined
·
13 Posts
Discussion Starter #5
Quick update, I wiped everything off as good as I could and I think it made a big difference if you compare the images. I'm no longer seeing clean oil anywhere else. The only spot where I'm seeing oil is still coming from behind the water pump (it's old/dirty oil for some reason). I've also placed shop towels on the floor and it's the only place where I see oil marks. With that said, what are my options here, should I just replace the entire waterpump or should I try replacing some of the O rings? I've read conflicting opinions on rebuilding the waterpump, some say to not mess with it. Can anyone offer suggestions where do I go from here?

Thanks in advance!

noleak2.jpg


noleak3.jpg


noleak4.jpg


waterpump_after.jpg


leak_after_clean.jpg
 

·
Registered
Joined
·
13 Posts
Discussion Starter #7
Wouldn’t the water pump be leaking coolant? Keep looking for the leak, take that front sprocket cover off.

Could be either or both. - I'll check behind the front sprocket cover as you suggested, is there anything specific there that could be leaking?
 

·
Registered
Joined
·
13 Posts
Discussion Starter #8
Well, I've found the source of the other leak. I don't know what this is called to even being to research this, so any help would be greatly appreciated.

new_leak.jpg


new_leak2.jpg
 

·
Registered
Joined
·
13 Posts
Discussion Starter #11
I really do not want to disassemble the engine. I covered the plug with Permatex Ultra black last night, I'm going to give it 24 hours to cure and then put oil back in the crankcase and see if that does it. I'll update this post later. I'm also rebuilding my water pump so that should cover both leaks. fingers crossed.
 
1 - 11 of 11 Posts
Top