Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 7 of 7 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
Hoping someone can help. I have an 06 gsxr 600. Yesterday i took it for a ride and after 1 hour the engine shut off while I was riding, the battery was hot and smoking. I changed the battery but still no start so i checked the fuses and the ignition fuse was blown so i replaced it and when i turn the key on it's ok until I turn the engine switch to on postion it immediatly blows the fuse. It doesn't even get to the point of engine check. All lights and cluster work. Maybe a short?
 

·
Registered
Joined
·
1 Posts
bumping and old thread but did you ever resolve this issue? this happened to me about 3 weeks ago, changed stator, reg, and battery, same issue with the ign fuse blowing out... ecu ordered and hopefully fixes the problem. also my front and rear blinkers dont work on the right side, left side does. any ideas?
 

·
Registered
Joined
·
60 Posts
I was able to fix my problem.
It ended up being the rectifier, battery and i had to replace the ECU. Something shorted out in the ECU and grounded a power wire.

Everything total it cost me about $350 to fix. I ended up upgrading to the R1 mosfet rectifier. I got a battery from my local battery supply store and I find an ECU on ebay for about $100.

I hope you figure it out.
 

·
Registered
Joined
·
6 Posts
could be you have live wires touching the frame also cluster of loom above coils behind headstcock [ under front of tank look for two yellow wires these get pinched just before the male and female joins twice happened to me over 30 years . Thing is you push your tank on to meet the two bolts at base of tank to tank bracket always pushing those wires up front .
 

·
That’s Mister Moderator To You ....
Joined
·
8,284 Posts
could be you have live wires touching the frame also cluster of loom above coils behind headstcock [ under front of tank look for two yellow wires these get pinched just before the male and female joins twice happened to me over 30 years . Thing is you push your tank on to meet the two bolts at base of tank to tank bracket always pushing those wires up front .
You do realize you're replying to a thread that's been dead for 9 years? AND WOULD YOU PLEASE try to use grammar and punctuation so people don't get a headache trying to understand your gibberish word salad.

PS: interesting choice of avatar?
 
1 - 7 of 7 Posts
Top