Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 4 of 4 Posts

·
Registered
Joined
·
1,014 Posts
Discussion Starter · #1 ·
I'm putting my bike together and find out that my headlights don't work. I am assuming that both relays are bad(I do find it odd that both are not working). Can the relays go bad from just sitting for over a year. If I bypass the relays the lights go come on, and I have power going to them but not comming out, so I assume that I am right.
I also have a problem with the side stand light not going aout when it is in the up position. I have tried pushing the button all the way in and it will not go out. I am at a loss on this one.
And last of all can anyone post any pictures of the wiring connectiors for the 86 750. The bike has been in pieces for so long I want to make sure everything gets connected properly.
I hate electrical problems


[ 06-05-2002, 05:47 PM: Message edited by: suzukiltd ]
 

·
Banned
Joined
·
11,514 Posts
both headlight relays can't be bad, check for another culprit

the sidestand switch is a bitch! remove it

the wires all plug into their own connectors, it is hard to mess them up (trust me, mine has been torn right down also)
 

·
Registered
Joined
·
1,014 Posts
Discussion Starter · #3 ·
Where do you guys have your main ground wire hooked to?
 

·
Registered
Joined
·
1,934 Posts
I don't have a bike in front of me but the main ground wire is usually connected to the engine. But it's a good idea to also run a lead from the frame to the battery as well. You can't have too many ground connections.

Like Mr. Gix says it's doubtful that both relays failed at the same time just from sitting. Sounds like you've checked to see that you have one terminal hot all the time. Now check to see that another terminal is turning on and off with the key (if the lights are supposed to be on all the time).
 
1 - 4 of 4 Posts
Top