Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 6 of 6 Posts

·
Registered
Joined
·
854 Posts
Discussion Starter #1
Hi,
I need your opinion.
My kill switch dont work anymore.My bike runs fine,i m just unable to shut it with the kill switch.It was working before I install a pair of Protek blue anodized bars(aftermarket clipons).

Does the kill switch ground the bike on the bar? Could it be the anodizing?

Thx for your help.
 

·
Registered
Joined
·
1,553 Posts
The kill switch cuts or 'open circuits' the positive power rail to the ignition coils and ECU.
Typically this would be a dedicated wire and not go through the clip-on.
It would appear that your switch is not able to break the circuit anymore.

The clip-ons are at ground potential. If you need ground at the clip-on you should thread a
dedicated wire otherwise you risk sparking across the head bearings.
 

·
Registered
Joined
·
2,130 Posts
Ur kill switch is in series with many other things on your bike, if ur kill switch wont kill the bike, then ur switch is bad, and not opeing the circuit when u flip it off. It could actually be that when u got ur bars done, some how the connections on the back of the swicth are touchen somehow.

ur kill switch does not ground anything out, its simply is inline with many other compents to make one complete path to make the bike start or not start.

D
 

·
Premium Member
Joined
·
7,715 Posts
Maybe you need a new kill switch. My .02
 

·
Registered
Joined
·
854 Posts
Discussion Starter #5
Ur kill switch is in series with many other things on your bike, if ur kill switch wont kill the bike, then ur switch is bad, and not opeing the circuit when u flip it off. It could actually be that when u got ur bars done, some how the connections on the back of the swicth are touchen somehow.

ur kill switch does not ground anything out, its simply is inline with many other compents to make one complete path to make the bike start or not start.

D
That s what i was thinking first.I will open the controls,maybe there is something bad with the wires.

Thx a lot guys
 

·
Registered
Joined
·
854 Posts
Discussion Starter #6
I find it.
It s my Dale Walker PowerShifter who do that.

The PS has a switch; on/off/bypass.
On bypass, my kill switch dont work.

I spent 45min %?%?((*&
i was checking at the harness(removed fairing) and opened the control to take a look at the wires.

So thx guys for your opinions.
 
1 - 6 of 6 Posts
Top