Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 8 of 8 Posts

·
Premium Member
Joined
·
4,142 Posts
Discussion Starter #1
Just had a new clutch and cam chain tensioner. Picked it up from the garage and having paid the bill got 1/2 mile down the road and its over heating! Figured i'd turn round and take it back, then it chugs to a halt and wont start.
Luckily the bike shop sent a mech out to help me bump start it and get it back to the garage.
Now, couple of things have started happening while it was in the garage - the oil light and oil can symbol are on all the time, the engine now sounds like a petrol lawn mower and its over heating.
The bike shop are all 'it cant be related to the work we did' but my point is these things werent happening before it went in!!!!
I dont know if any of you have suggestions on the cause of any of the symptoms, or even comments - all welcome. Just fed up with it at the moment...............


My GSXR
 

·
Registered
Joined
·
737 Posts
Typical customer...you assume that your fuel pump went out because the shop changed your wiper blades. Chill and let them see what's wrong. Maybe it was there fault or maybe it's another part that had nothing to do with their work.
 

·
Premium Member
Joined
·
4,142 Posts
Discussion Starter #3
Typical customer...you assume that your fuel pump went out because the shop changed your wiper blades.
Thanks for the help.

The bike <u>is</u> back with the garage and i <u>am</u> waiting for them to let me know whats going on. I appreciate that theres a 99% chance that the new problems are completely unrelated, but thought the good people of this forum might tell me if there was any possible connection.

Maybe it makes me a lesser mortal, but i dont know much about bike mechanics, so i need to make sure that im not being taken for a 'ride' (bad choice of words???) after being ripped off in the past.
Before you say it yes, this is a different bike shop with different people, and i dont think they would rip me off.
The fact that they sent a mech out to help me out speaks volumes, alot of places wouldnt have done anything like that.

Cheers.
 

·
Premium Member
Joined
·
4,142 Posts
Discussion Starter #4
Hey Racer313g,
I owe you an apology, didnt mean to sound aggro. Just a little annoyed.
Youre right in what you said, i just have to wait and see whats up with it.

Sorry man.
 

·
Premium Member
Joined
·
4,142 Posts
Discussion Starter #7
think its gonn abe cheapest to buy a second hand engine and get it fitting. Theres some worry about engine damage caused by low oil pressure, and the labour costs involved in finding the problem. Then theres the parts costs to fix what evers bust.

damn. there goes my summer.
 

·
Premium Member
Joined
·
4,142 Posts
Discussion Starter #8
confused............
just picked my bike up from one garage to take it to another, started it to get it up the van ramp and.............

runs sweet as a nut


either the tech spotted something he missed and fixed it, or it was a blockage of somekind and fixed itself........

hey ho, at least the fucker (are rude words allowed?) runs now.
 
1 - 8 of 8 Posts
Top