Suzuki GSX-R Motorcycle Forums Gixxer.com banner

Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #1
HEY guys new to the forums, I have a 2007 gsxr 750. The bike runs great, it just doesn’t want to start normally. It will crank for 10 seconds then backfire and eventually start. This is what has been done so far.
Valve adjustment, four valves were tight and they were adjusted.
The TPS was set
Fuel pressure was tested
Compression test was good
Cmp code was on, but the sensor was removed and tested ok
Repaired pin #29 on ecm
Plugs are new
The bike runs perfect and doesn’t hiccup at all. Revs fine, low speed performance is good. Will pull all the way to redline.
It has a TRE in it, but was removed and our back to stock to no avail.
I was told by this shop which is Motorsports nation in Waterford ct, which is a certified Suzuki dealership with master techs, that they have no idea what is wrong. They told me it could be a bad ecm. That is a $1300 dollar gamble.
Any good advice where I should go from here? I want them to contact Suzuki and see what they say. One of the techs went so far as saying just get out of the bike before I spend too much on it. I’m not willing to give up that easy.


So I bought a new cam position sensor and crank position sensor. The shop told me they removed both sensors cold and they both tested ok, but when they put them back in the bike fired up instantly. Once it got warm it started to do the same exact thing. I also have an ECM on the way I purchased for 375. What a pain in the ass to find an 06-07 ECM unit. The bike did not do this when I bought it and it started as a hot start issue and now it has progressively turned into an all the time issue. I am at my wits end with this bike, I literally am loosing sleep over it. ANY input is more than welcomed, I will remain open to anything at this point. I am just throwing money and parts at it on a whim more or less. Anyone know of any good shops in New England??? Or even the east coast? Because I don’t know what to do or what where to go from this point. Especially if I put these two sensors and ECM in and it has no affect.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #4
But I really appreciate the fact that you just came here to correct and me offer no valuble help what so ever. Don’t over extent yourself here lmao
 

·
Ex-Lady Supermod
Joined
·
16,100 Posts
But I really appreciate the fact that you just came here to correct and me offer no valuble help what so ever. Don’t over extent yourself here lmao
Oh, alright I will give you some help. Read forum descriptions before posting 'cause you know "A place for everything and everything in its place" and just because you have a water cooled carb bike does not make this the right place to ask about an 07 FI bike :kiss2:
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top