Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 5 of 5 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
I have a problem with my motorcycle. It is a Hayabusa 2004. It is that when I change the coolant and the oil with filter I put the key on and when I gave the switch voltage to start it dropped the voltage and the dash went out and there was no power again. The battery has full voltage but the fuses do not, I check the red switch (on and off to the current) and it works correctly, it has continuity. Now the question is; What happen with the motorcycle that does not have voltage to start?
Thanks for all the help that you people can give to me on this!!!
 

·
Ex-Lady Supermod
Joined
·
16,100 Posts
The battery has full voltage but the fuses do not, I check the red switch (on and off to the current) and it works correctly, it...
Not sure what you mean by fuses don't have full voltage? Check the battery voltage with ignition off and with ignition on. A battery can show full voltage/good but that may not be the case.
 

·
Registered
Joined
·
2 Posts
Discussion Starter #3
the batery has 13 + volts with ignition off or on and the fuses never shows voltage on any ignition position
 

·
I know things... A lot of things.
Joined
·
3,180 Posts
If the battery does hold its voltage as you turn the ignition switch on, try following the negative battery lead to the engine ground point and check if the latter is clean, free of rust and tight.
 

·
Premium Member
Joined
·
3,754 Posts
also, after checking your wiring, think what could you have done between the last ride and oil change to have maybe crated the issue?

did you move any wires around anything like that?

can't imagine what you could have moved electrically but I don't know what all you touched during the procedure?

perhaps you can walk us through your actions?
 
1 - 5 of 5 Posts
Top