Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
7 Posts
Discussion Starter #1
So I have a 07 /750
Rode the bike one night and it started acting funny, every time I pulling back on the throttle more and more it jerks like it’s running out of gas! So I pulled over to see what it was doing. Got back on high way and still was bogging every time and act like it wanted to die.. Now it won’t start at all & F1 light on.
Put in dealer mode and the code it gave me is C41. The throttle bodies not opening also fuel pump prime for 1 sec!
I bought a new ecu and bike still didn’t start! HELP ME OUT!!!! Please
 

·
You should listen to me. No, seriously, listen to
Joined
·
8,616 Posts
Try swapping the fuel pump and fan relays. Measure the voltage at the Y/R lead at the fuel pump and at any injector. It's also at the ECM. They should be 12 V when priming but then probably go to zero till it starts. Do the fuel pump flow rate test to make sure that the filter isn't clogged. Will it run briefly if you prime it?
 

·
Registered
Joined
·
7 Posts
Discussion Starter #3
Try swapping the fuel pump and fan relays. Measure the voltage at the Y/R lead at the fuel pump and at any injector. It's also at the ECM. They should be 12 V when priming but then probably go to zero till it starts. Do the fuel pump flow rate test to make sure that the filter isn't clogged. Will it run briefly if you prime it?
I changed the fuel pump filter and the motor was rusted Bradley! Still no start! The battery is new!
 
1 - 3 of 3 Posts
Top