Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 1 of 1 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter · #1 · (Edited)
Hey everyone, I have a 2007 GSXR 750 that I rebuilt from a minor wreck that happened back in December 2019. Recently, my bike has been losing power and then dying on the highway. I replaced the stator, rectifier/regulator(with OEM and I did a mulitmeter test on it. Stator was above 65 volts in all 3 phases and also had no numbers when I checked for short to ground. The rectifier was around 49 volts in all phases) and the battery with a yuasa 12V. Bike worked fine and started up with no problem, did not lose power, and turned right back on after being turned off for 3 days. Today it lost power and died twice. I was able to jump start it and ride it home. As soon as I turned the bike off, it won’t start up again. I don’t think it’s a battery problem because the gage cluster and all the lights, turn signals, horn, etc. come one when the key is turned on. The bike just won’t start. I just checked all the fuel lines, kickstand sensor, everything is good. I have been noticing that whenever I am stopped at a stop light and I put the bike in neutral, the neutral light is very dim and barely comes on. Also in 1st gear, once you get above 6k rpm, the bike makes a terrible noise like someone is scratching their nails against a chalkboard. Could this be because of the spark plugs? Thanks.
p.s. before the wreck I had the bike for about 4 months and never had any problems with it at all. Always started up perfectly fine and had no issues with power or anything.
 
1 - 1 of 1 Posts
Top