Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 20 of 99 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1 (Edited by Moderator)
NOTE: If you follow these instructions, you'll get -C00 with few exceptions. When you go to put it in dealer mode, it must show FI on the dash and you must put it in dealer mode without turning off the ignition at key and/or kill switch or you erase the code(s). Then you have to wait till FI pops up again, take it to a dealer or buy the SDS tool to pull the stored codes.

Amidst all the dealer mode threads that don't sufficiently cover location and bypass for the 06/07 GSXR 750, here is a comprehensive guide.

What is dealer mode? This activates the diagnostic system on your GSXR 750. It will indicated a code on your instrumentation panel which is associated with a system failure. The codes are as follows:
C14 - THROTTLE POSITION SENSOR
C15 - ENGINE COOLANT TEMPERATURE SENSOR
C21 - INTAKE AIR TEMPERATURE SENSOR
C22 - ATMOSPHERIC PRESSURE SENSOR
C23 - TIPOVER SENSOR
C24 - IGNITION SIGNAL #1
C25 - IGNITION SIGNAL #2
C26 - IGNITION SIGNAL #3
C27 - IGNITION SIGNAL #4
C28 - SECONDARY THROTTLE VALVE ACTUATOR
C29 - SECONDARY THROTTLE POSITION SENSOR
C30 - SECONDARY THROTTLE CONTROL UNIT
C31 - GEAR POSITION SENSOR
C32 - INJECTOR SIGNAL #1
C33 - INJECTOR SIGNAL #2
C34 - INJECTOR SIGNAL #3
C35 - INJECTOR SIGNAL #4
C41 - FUEL PUMP CONTROL SYSTEM
C42 - IGNITION SWITCH SIGNAL
C46 - EXHAUST CONTROL VALVE ACTUATOR (1000 ONLY)

Step 1: Remove seat. There is a bolt on each side of the seat, an inch below.
Step 2: (reference picture series below) Locate the dealer terminal. It is described as a six prong, white in color plug with a black rubber dust cap. The plug may be found under the subframe support truss shown in the picture.


Step 3: Remove black dust cap and expose contacts. Now examine wires and locate a black wire that has a thin white stripe. Locate the second wire which is a white wire with a thin red stripe. Now use an insulated wire (speaker wire will do) to connect the black/white contact to the white/red contact. They should be adjacent to each other.


Step 4: With the kill switch selector on "off", turn the ignition system to the start position. The motorcycle instrumentation, headlight and tail light should all be on at this point. Now, flip the kill switch from "off" to "on" to activate the FI system. You are now in dealer mode. "C00" means your bike is like that friend that complains just about everything when there is really nothing wrong.
 

·
Registered
Joined
·
639 Posts
just did some searching. this trick will display the computer diagnostic trouble codes that the dealer uses to diagnose the FI light on your bike, saving you an $85 diagnostic charge.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #5
Exactly, here is a list of possible failures:

C14 - THROTTLE POSITION SENSOR
C15 - ENGINE COOLANT TEMPERATURE SENSOR
C21 - INTAKE AIR TEMPERATURE SENSOR
C22 - ATMOSPHERIC PRESSURE SENSOR
C23 - TIPOVER SENSOR
C24 - IGNITION SIGNAL #1
C25 - IGNITION SIGNAL #2
C26 - IGNITION SIGNAL #3
C27 - IGNITION SIGNAL #4
C28 - SECONDARY THROTTLE VALVE ACTUATOR
C29 - SECONDARY THROTTLE POSITION SENSOR
C30 - SECONDARY THROTTLE CONTROL UNIT
C31 - GEAR POSITION SENSOR
C32 - INJECTOR SIGNAL #1
C33 - INJECTOR SIGNAL #2
C34 - INJECTOR SIGNAL #3
C35 - INJECTOR SIGNAL #4
C41 - FUEL PUMP CONTROL SYSTEM
C42 - IGNITION SWITCH SIGNAL
C46 - EXHAUST CONTROL VALVE ACTUATOR (1000 ONLY)

The code you want to get is "C00" which means there is no problem. I will make the edit so that the purpose of dealer mode is made clear.
 

·
Registered
Joined
·
4 Posts
Question,,, I am placing a new engine in my 03 gsxr 600 and I need to no, where does the STVA cable hook up at, If I am correct, one side hooks up where the throttle cables hook up at and I need to no where the other side hooks up at? Any help would be appreciated, also I am using the 02 750 clip ons and forks etc.. I dont remember if the 02 750 had the STVA cable or not.

Please help! email [email protected]
 

·
Registered
Joined
·
2,440 Posts
Exactly, here is a list of possible failures:

C14 - THROTTLE POSITION SENSOR
C15 - ENGINE COOLANT TEMPERATURE SENSOR
C21 - INTAKE AIR TEMPERATURE SENSOR
C22 - ATMOSPHERIC PRESSURE SENSOR
C23 - TIPOVER SENSOR
C24 - IGNITION SIGNAL #1
C25 - IGNITION SIGNAL #2
C26 - IGNITION SIGNAL #3
C27 - IGNITION SIGNAL #4
C28 - SECONDARY THROTTLE VALVE ACTUATOR
C29 - SECONDARY THROTTLE POSITION SENSOR
C30 - SECONDARY THROTTLE CONTROL UNIT
C31 - GEAR POSITION SENSOR
C32 - INJECTOR SIGNAL #1
C33 - INJECTOR SIGNAL #2
C34 - INJECTOR SIGNAL #3
C35 - INJECTOR SIGNAL #4
C41 - FUEL PUMP CONTROL SYSTEM
C42 - IGNITION SWITCH SIGNAL
C46 - EXHAUST CONTROL VALVE ACTUATOR (1000 ONLY)

The code you want to get is "C00" which means there is no problem. I will make the edit so that the purpose of dealer mode is made clear.
Nice write up. :cheers

But you forgot a couple things. :cursing

A) The ( - ) line infront of the ( C ) indicates the position of the throttle position sensor or TPS
It should be in the middle while the engine is running. If it is at the bottom or top of the ( C ) then it needs adjusted. This sometimes cures the herky jerky throttle problem.

B) The codes you have listed are for the 2004 GSXR1000
Our bikes have a few more codes.....as listed below
 

Attachments

·
Registered
Joined
·
12 Posts
Can you stop and / or start your bike while you have these two pins jumpered together? Can you just jumper the two wires together right off the bat and then do what you need to do to get your bike to error out? Did I miss this part?
 

·
Registered
Joined
·
12 Posts
Can you stop and / or start your bike while you have these two "Dealer mode" pins jumpered together? Can you just jumper the two wires together right off the bat and then do what you need to do to get your bike to error out? My bike only flashes f1 after it is good and hot and I shut it off and let it sit for a few minutes. then I start it, it flashes f1, then I shut it off, jumper the pins together and it says C00. So can I jumper this connector before I begin these shenanigans?
 

·
Registered
Joined
·
2,440 Posts
Yes,

but my advice would be to do it when the light comes on, as you will lose some info on dealer mode such as temp gauge. In addition, I believe that in dealer mode the SET is not working (has to do with calibration) and is stopped mid way. So it would be possible that other controls are set on a "safe" mode, maybe even engine mapping.

Just carry a paperclip and if it comes on, pull aside, and put it in dealer mode without turning the engine off.
 

·
Registered
Joined
·
310 Posts
Nice write up. :cheers

But you forgot a couple things. :cursing

A) The ( - ) line infront of the ( C ) indicates the position of the throttle position sensor or TPS
It should be in the middle while the engine is running. If it is at the bottom or top of the ( C ) then it needs adjusted. This sometimes cures the herky jerky throttle problem.

B) The codes you have listed are for the 2004 GSXR1000
Our bikes have a few more codes.....as listed below
If my (-) line in front of the C is at the top with the engine off...would that creat an issue with starting?? I'm having a hard time starting it with no fi codes. she backfires while being started sometimes too, but I can push start it...
 

·
Pathalogical Poser
Joined
·
6,571 Posts
the - only applies while the engine is running, at proper idle speed, witht he throttle control fully off (twisted forward). if the engine is not running, or if you are twisting the throttle, or if your engine idle speed is not set correctly, then that - means nothing to you.
 

·
Registered
Joined
·
712 Posts
this should be a sticky as i think it took Joe like 10 posts to walk me through this while he was on the road one day..
 

·
Registered
Joined
·
2 Posts
My red light has been on intermediately for months. Now the red light is on continuously along with the and f1 symbol blinking from the time I start it up to when I turn it off.

I did the diagnostic mode on it and it still showed up -C00 ... what gives? I know something is wrong with the damn thing since when I ride it for awhile during the day time heat it won't rev past 10k rpm at night when I ride when its cold it goes past it easily. Either way the red light is always on and the F1 symbol blinks in and out at all times as well.
 

·
Registered
Joined
·
4 Posts
this worked perfect for me. I had my FI light on solid for 3 days. jumped the wires got a C00. took the wire out, the light turned off. hopefully it will stay off for awhile now.
 

·
Registered
Joined
·
371 Posts
Nice write up. Thanks! Just one question... Does this apply to the 600 as well, I mean as far as jumping the same wires and everything? Im assuming it does since the 600/750 are virtually identical. But just making sure before I go fry anything by crossing the wrong wires. Also I only get an FI code like once every few weeks...
 
1 - 20 of 99 Posts
Top