Suzuki GSX-R Motorcycle Forums Gixxer.com banner
Status
Not open for further replies.
1 - 5 of 5 Posts

·
Registered
Joined
·
3 Posts
Discussion Starter · #1 ·
Fellow gixxers,

5 Months ago I bought a GSXR750 from 1998.
It had only 16.000 km on the clock.

When I start riding everything works fine, pulling through the revvs like it supposes to do.
But somewhat later the bike doesn't go to the top rpm's anymore. It gives hick-ups, holding back and doesn't accelarate like it's meant to do ....
Sometimes it doesn't even comes over the 6000 rpm !!

Somebody any suggestions? Or had same experiences?

My dealer tried, and obviously he didn't find anything.

Looking forward to a reply,

GSX-Ray.
 

·
Premium Member
Joined
·
117,182 Posts
My buddies R6 is having a similar problem around 10k rpm. It also does it under heavy load. His almost sounds like the rev limmiter is hitting because it is breaking up so bad.

So far we have changed plugs, adjusted valves and are in the process of rejetting today.
I'll let you know if it does the trick.
If it doesn't work my next guess is something with the ignition
just a few questions
has it had a valve adj.?
have you put a new pipe or filter on it?
Is the filter and air box clean?
How do the plugs look?

I am a mechanic at a shop Ill try ro help if I can
 

·
Unstable SuperMod
Joined
·
21,904 Posts
I've had the same problem on my '92 750, pulls great till around 14,000, then there is not much left, what do you think it might be??
 

·
Registered
Joined
·
7,958 Posts
OK, I'm moving this to the 96 - 99 where it will get a serious answer!
 
1 - 5 of 5 Posts
Status
Not open for further replies.
Top