Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter #1
Hi! This is my first post and i'm sorry if there is already thread around the subject.

I got myself this 2006 GSX-R 600 and everything seemed great. It was restricted to 25kw, but also came with the 92 kw ecu. 26 000km, which isn't too bad for these restricted bikes in here. The bike was clean and had all the stock parts (licence plate holder, stock muffler/silencer, passenger pegs). The history also checked. The first time i took the bike for serious ride, it lacked some serious power. First i checked all the basic things, like the spark plugs, filters and the throttle valves. But no, it didn't work. After that i took it to service where he found out, that the voltage regulator was blown. That's all that he could find out because the lack of eguipment. He told me this other service out of town had a dynometer and i took the bike there. This guy took some serious time with the bike and this is what he found out:

One jet had wiring problem, which he fixed
The bike was running rich, which he fixed
There was no FI codes
O2 sensor gave some weird readings
Sometimes the fan went on when the power was turned on
The "full power" ecu was sketchy (probably some wrecker ecu and the key filed to fit, because all three keys fitted the lock, 2 for the restricted, one with the "full power" one)
When in neutral, everything was ok. But once you put in the first gear (or any other gear), the timing advance would disappear. (tried to fix, but with his equipment, could advance 5°-10° which wasn't enough)

Service told me that the bike was in this limp-mode like state, but then again there was no codes. Also the ecu thing was confusing. The guy actually told me to sell the bike and get another one. Or if i wanted to waste more money, i could get Power Commander with ignition map stuff. But we both agreed that probably the thing causing these problems would nullify the commander.

With the 25kw ecu the max speed is around 130 km/h and should be around 180-190 km/h?

I'm going to sell the bike due to the frustration, but if anyone has ideas of how to fix these problems, they would be much appreciated. I could sell a working bike for a proper price.
 

·
Registered
Joined
·
106 Posts
Hi! This is my first post and i'm sorry if there is already thread around the subject.

I got myself this 2006 GSX-R 600 and everything seemed great. It was restricted to 25kw, but also came with the 92 kw ecu. 26 000km, which isn't too bad for these restricted bikes in here. The bike was clean and had all the stock parts (licence plate holder, stock muffler/silencer, passenger pegs). The history also checked. The first time i took the bike for serious ride, it lacked some serious power. First i checked all the basic things, like the spark plugs, filters and the throttle valves. But no, it didn't work. After that i took it to service where he found out, that the voltage regulator was blown. That's all that he could find out because the lack of eguipment. He told me this other service out of town had a dynometer and i took the bike there. This guy took some serious time with the bike and this is what he found out:

One jet had wiring problem, which he fixed
The bike was running rich, which he fixed
There was no FI codes
O2 sensor gave some weird readings
Sometimes the fan went on when the power was turned on
The "full power" ecu was sketchy (probably some wrecker ecu and the key filed to fit, because all three keys fitted the lock, 2 for the restricted, one with the "full power" one)
When in neutral, everything was ok. But once you put in the first gear (or any other gear), the timing advance would disappear. (tried to fix, but with his equipment, could advance 5°-10° which wasn't enough)

Service told me that the bike was in this limp-mode like state, but then again there was no codes. Also the ecu thing was confusing. The guy actually told me to sell the bike and get another one. Or if i wanted to waste more money, i could get Power Commander with ignition map stuff. But we both agreed that probably the thing causing these problems would nullify the commander.

With the 25kw ecu the max speed is around 130 km/h and should be around 180-190 km/h?

I'm going to sell the bike due to the frustration, but if anyone has ideas of how to fix these problems, they would be much appreciated. I could sell a working bike for a proper price.
06 and 07 600 don't have a o2 sensor in the US might be different in other countries?
How did he fix the rich condition?
The fan would go one if the motor is over 200F
so you have two ecus? are they both the same ECU?
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,783 Posts
It sounds like I'm asking the wrong person but here goes anyway. How was the 25 KW limit achieved in the first place? How was the service guy adjusting the timing? The ECM(s) should have a part number on them. Are they correct for the bike? Not sure about yours but on others the fan comes on briefly several times during warm up if the RPM is above 4000 RPM.
 
1 - 3 of 3 Posts
Top