Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 2 of 2 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I have a 2007 GSXR600, I bought this bike used and I was having issues with the fuel pump relay throwing the code multiple times while riding, causing me to lift up the gas tank and move the wires around. Since I keep having this issue I pulled the relay and cables off of the stock hanger and I have them taped on the outside of the tank so I can quickly mess with the wires to get the bike running again. The FI code only appears, shuts the bike off, then goes away after fidgeting with the relay and wires. Ive read through a couple posts about removing the "Set Valve", but I dont know if this is going to fix my issue. Should try to replace the relay or Is there a different issue typically with this bike. Also using the paper clip technique it gave me code C41.
 

·
I know things... A lot of things.
Joined
·
3,124 Posts
If you get a C41 and have to fiddle with the wires to get the bike running, then your problem is most likely wiring-related and can only be fixed by fixing your wiring. Relocating the parts for easier fidgeting doesn't count.

Get a service manual and consult the diagram on page 4-83. As you can see, there's a lead from the output of the relay that feeds the fuel pump (Y/R) that goes to the ECU. The ECU only monitors the voltage on that lead to figure out whether the pump is getting power when and only when the ECU has commanded the relay to turn on.

That lead is probably broken somwhere between the relay and the ECU. You'll need to use a DMM to figure out whether that's the case, whether it affects the ECU only or the pump as well and how to best fix it.

In the last page of the service manual you can see a wiring diagram, which may also be of help.
 
1 - 2 of 2 Posts
Top