Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 6 of 6 Posts

·
Registered
Joined
·
210 Posts
Discussion Starter · #1 ·
Problems, change my exhaust system on my 01 GSXR 1000 to a Ti-froce slip on, now when I reach a range of 9000 rpms' during hard accelluration, gas seem to choke off. When I gradually roll on the throttle gas flows fine. I've checked the fuel line for cramps, throttle position sensor code at -COO in center. Ran with power commander USB connected and unconnected, K&N airfilter clean, tried three or four different maps, removed airbox an check to see if throttle bodies flap open when opening the throttle, working fine. I've tried everything I can think of and finally at the end of an rope
 

·
Registered
Joined
·
941 Posts
Fuel filter not letting enough gas by under hard acceleration....Makes since, but i'm not a mechanic and I didn't see that listed above...

Or maybe the fuel pump is acting up and not pumping enough gas at WOT?
 

·
Registered
Joined
·
210 Posts
Discussion Starter · #3 ·
Thanks for the input. I pulled the top fuel line off and turn the switch on, fuel flows out but I'am not sure if this telling me what I need to know, if the bike not at wide open throttle. The dealership close today for the holiday and can't speak with a Tech. I'am hoping one of my gixxer bro's with tech. knowledge or someone with prior problems can help me out, by responding to this post
 

·
Registered
Joined
·
210 Posts
Discussion Starter · #4 ·
After all the trouble shooting done, It came down to dirty fuel Injectors, all four. Pulled off throttle bodies, removed all four Injectors sprayed with carb cleaner, problem solved.
 

·
Registered
Joined
·
941 Posts
good going....
 

·
Registered
Joined
·
210 Posts
Discussion Starter · #6 ·
One thing I've learn about having a motorcycle, is to learn everything about the up keep of your machine, It will save you a alot of out of pocket money, if your not afraid to be an hands on guy
 
1 - 6 of 6 Posts
Top