Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 20 of 265 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'm looking for some info. I was riding to work this morning and I stopped to get gas and about five minutes into the ride the FI light came on and the FI code was flashing in the display. I continued to ride and notice that in the higher RPM range the response was hesistant. When I stopped the idle was a little high and it didn't sound normal. Eventually the idle and the throttle response seemed to be normal again, but the error was still there. I got to work shut the bike off started it again and the error was gone. Could this just have been from bad gas?
 

·
Registered
Joined
·
6,886 Posts
Open your rear seat and you'll see a black cap covering a connector/harness on the left side of the seat. If you take the cap off, you'll see it appears to be a normal harness. With your key in the ignition and bike turned to "on" (but not running), take a paperclip and short the two connectors out (by touching the two contacts together). This is known as a "ghetto dealer mode switch". It should display the error code on your display instead of just FI now. You might want to consider buying JeffW's Dealer Mode switch...He's an upstanding guy (ask anybody on gixxer.com) and sells great products.


GSXR Fuel Injection (FI) Code List:

C14 - THROTTLE POSITION SENSOR
C15 - ENGINE COOLANT TEMPERATURE SENSOR
C21 - INTAKE AIR TEMPERATURE SENSOR
C22 - ATMOSPHERIC PRESSURE SENSOR
C23 - TIPOVER SENSOR
C24 - IGNITION SIGNAL #1
C25 - IGNITION SIGNAL #2
C26 - IGNITION SIGNAL #3
C27 - IGNITION SIGNAL #4
C28 - SECONDARY THROTTLE VALVE ACTUATOR
C29 - SECONDARY THROTTLE POSITION SENSOR
C30 - SECONDARY THROTTLE CONTROL UNIT
C31 - GEAR POSITION SENSOR
C32 - INJECTOR SIGNAL #1
C33 - INJECTOR SIGNAL #2
C34 - INJECTOR SIGNAL #3
C35 - INJECTOR SIGNAL #4
C41 - FUEL PUMP CONTROL SYSTEM
C42 - IGNITION SWITCH SIGNAL
C46 - EXHAUST CONTROL VALVE ACTUATOR (1000 ONLY)
-=bmacd=-
 

·
Registered
Joined
·
6,886 Posts
jayson001 said:

Thanks. Is it safe to ride home with it like that?
Ride home like what? A) With the FI light on or B) with the paperclip in the harness?

A) it depends on what the FI code is. If you post what the code reads, then we can take it from there.
B) You only need to use the paperclip in the harness for as long as it takes you to read the code, and then you take the paperclip out. I'm sure it wouldn't do any damage to the bike if you had to ride with the paperclip in, but you might as well take the safe route and pull it out. Besides, it only takes two seconds to put it in anyway...

-=bmacd=-
 

·
Registered
Joined
·
490 Posts
I had my FI light come on last week while on the highway coming home from NH. It was like 100 degrees out that day and I had just gotten gas from some sketchy station up there. I rode the rest of the way home since everything felt normal. Started it up the next day and no FI light anymore and hasn't shown up since. I wish I could have gotten the code number to see what it was, but now I can't unless it comes back on sometime in the future.
 

·
Registered
Joined
·
4 Posts
Discussion Starter #7
I think this has happened before I got gas and right after that it began to act funny. I didn't notice the FI light on though. I called the shop and they weren't really any help. I just want to make sure I can get it home without doing any damage.
 

·
Registered
Joined
·
490 Posts
Do what they said with the paper clip, the codes are int he y2k and beyond forum. Its like the first thread in there. If you have any trouble let me know
 

·
Registered
Joined
·
69 Posts
I have an 03 1000 and now my FI light is on.... I have read the forum here and my question is this. How many pins are on the connector in the trunk that I need to cross? The only 2 pin connectors in my trunk are the blinkers and the tag light. I have taken all the plastics off the subframe.. simply no 2 pin connectors other than the ones I mentioned. Any help would be huge. Thanks.
 

·
Registered
Joined
·
69 Posts
Well.... It took me several days some trial and error and a shop to loan me a dealer mode switch but I found the wires. The dealer switch I borrowed was wrong for my bike but I managed to find the wires. On the K3 1000 there is a six pin connector in the trunk with a rubber boot covering it. Cross the black wire with the white stripe with the white wire with the red stripe to go into dealer mode. Amen.
 

·
Registered
Joined
·
3 Posts
GSXR Fuel Injection (FI) Code List:

C14 - THROTTLE POSITION SENSOR
C15 - ENGINE COOLANT TEMPERATURE SENSOR
C21 - INTAKE AIR TEMPERATURE SENSOR
C22 - ATMOSPHERIC PRESSURE SENSOR
C23 - TIPOVER SENSOR
C24 - IGNITION SIGNAL #1
C25 - IGNITION SIGNAL #2
C26 - IGNITION SIGNAL #3
C27 - IGNITION SIGNAL #4
C28 - SECONDARY THROTTLE VALVE ACTUATOR
C29 - SECONDARY THROTTLE POSITION SENSOR
C30 - SECONDARY THROTTLE CONTROL UNIT
C31 - GEAR POSITION SENSOR
C32 - INJECTOR SIGNAL #1
C33 - INJECTOR SIGNAL #2
C34 - INJECTOR SIGNAL #3
C35 - INJECTOR SIGNAL #4
C41 - FUEL PUMP CONTROL SYSTEM
C42 - IGNITION SWITCH SIGNAL
C46 - EXHAUST CONTROL VALVE ACTUATOR (1000 ONLY)


which one of this codes should i use for the FI lights?.... dont know .........please help.... i still afraid to ride my bikke now.....help......help...help...help;...help...
 

·
Registered
Joined
·
69 Posts
You have to put your bike in dealer mode.... lots of threads on how to do it.
Once its in dealer mode it gives you the code so you know where to look for the problem.
 

·
Registered
Joined
·
32 Posts
sanhlubyee

What you have to do is ,

1. Get the bike running and the FI light to start flashing.

2. Keep the bike turned on so the FI light doesnt go off

3. remove the left hand rear side fairing

4. Bridge the 2 wired of the diag. connector

5. Look at your clocks again, the FI light will go out and be replaced with one of the codes.

There you have it.


But saying that, i had a problem on mine with the Fi light, Code showed c27

After the hesitation got worse and it didnt start in the mornings, changed the battery and has been perfect since.
 

·
Registered
Joined
·
16 Posts
so i tried shorting the two wires together and consequently heard a fuse pop. i guess im on the wrong connector...? it has a fender eliminator kit and leds on the tail. it looked like the only connector that was unused. the fuse was to the turn signals. i just got the bike home tonight. its a 2k4 750 with 9400 miles thanks for any additional help.

:confused :confused
 

·
Premium Member
Joined
·
580 Posts
Whenever it is hot and the humidity is high here on LI, I always get the FI light and it turns out to be a C21. I guess the intake air sensor gets moisture on it from condensation and cannot pass an accurate reading. Usually it just takes a quick shut down and re-start and it clears.
 

·
Banned
Joined
·
65 Posts
lol ok well i have C13 as a code
 

·
Registered
Joined
·
209 Posts
12go186mph said:
Well.... It took me several days some trial and error and a shop to loan me a dealer mode switch but I found the wires. The dealer switch I borrowed was wrong for my bike but I managed to find the wires. On the K3 1000 there is a six pin connector in the trunk with a rubber boot covering it. Cross the black wire with the white stripe with the white wire with the red stripe to go into dealer mode. Amen.
+1 Thanks for the K3 1K info, helped me out a lot with mine. Damn SET valve. ;)

KeS
 

·
Registered
Joined
·
2 Posts
we have a problem in hayabusa 05 the fI light appear on my bike after i turn it on and the rpm go to 5500.so i checked the codes and it gaves me that the problem from c24 and c27 all i need to know how i can reset it .thanks for helping me
 
1 - 20 of 265 Posts
Top