Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter #1
Hey guys....Im new to the site and totally new to motorcycles. I just bought my 1999 Gixxer 600 a couple weeks ago. Havent done too much riding on it. But sometimes when I go to start it, it starts but dies on me and shuts off after a few seconds. Then the oil light starts flashing. Then other times I'll start it up and ride around on it in first gear and it seems totally fine.

Then today I got on it rode it for a bit it was fine. Turned it off, went to start it again, shut off on me. Now it wont start. Goes to turn over but does nothing. I just checked the oil levels in it, seems like it has too much oil in it. If I drain the oil and put new in up to the required amount....should this fix the problem? Is there anything else I should look into?
 

·
Registered
Joined
·
5 Posts
Hello All,
I also have a similar problem. I have a 2002 gsx-r 750, and it shuts off if RPM is around 7k or so. it does have too much oil, could it be the cause of shut off? Please let me know!
 

·
Registered
Joined
·
195 Posts
Someone correct me if I am wrong but if you have tooo much oil in then you can cause air bubbles in your engine (not good) which I would think would make it shut off. Ive always heard its better to put a little less than a little more.

I only have experience with my kaw 250 and that is what I have learned from the professionals from my previous board.

EDIT: Sorry for resurrecting this from the grave, didnt even look at the dates lol
 
1 - 3 of 3 Posts
Top