Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 9 of 9 Posts

·
Registered
Joined
·
8 Posts
Discussion Starter #1
Can anyone explain why my GSXR1100M cuts all power to the engine and the tacho at 7500 rpm in every gear. the engine reacts as if the kill switch had been used.when i pull in the clutch ie the engine is no longer under load the engine revs freely to the red line. I have checked all block conecters and they seem fine!!!!!!!!!
 

·
Registered
Joined
·
124 Posts
agree with mrtris. when you have probs with ignition on a gsxr check the cdi first.... see if you can swap with someone who has the same one.
 

·
Registered
Joined
·
1,103 Posts
and from me too, swap the CDI black box with a friend to see if it's that. It probably will be !
 

·
Registered
Joined
·
1,103 Posts
try the colis then.maybe they are breaking down under load ?

Andy.
 

·
Registered
Joined
·
8 Posts
Discussion Starter #7
Argh!!!!!!!!!!!!!!!!!!!!!! Problem sorted. Bloody side stand cut out switch must have been vibrating at the right pitch at 7500 rpm under load to cause complete power cut to the coils !!!
I`ve joined the 2 wires together and once more the birmingham hooligan hits the road with full power.

Cheers to all who helped
 

·
Registered
Joined
·
12 Posts
I had a similar problem on my '90 750. After doing everything I could possibly imagine ( i'm sure you've tried), mine turned out to be the kickstand. The spring gets old and the stand vibrates down just enough to cause the bike to turn on and off quickly. Safety wire the stand up, unplug the sensor, whatever, take it out of the equation.
 

·
Registered
Joined
·
7 Posts
dunno if this is any help but on my 89 1100, hit a bump and the engine cut out and then back in immediately, turns out not to be the side stand switch but the relay in the afforementioned circuit!
hope this helps someone.
 
1 - 9 of 9 Posts
Top