Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 7 of 7 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I know that no-one will probably be able to help but.... my GSXR 600 K1 (2002) has an electrical fault... it died on me while I was riding it (FI light flashing), managed to get it to a garage and they had a tinker with it, changed a couple of fuzzed up connections.... managed to get the fuel pump to prime (which it wasn't doing before) but now it runs for about 10 seconds and cuts out..... They've changed a couple of relays and still doing it...

Any ideas?
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #2 ·
Just for an update, I'm now being told its engine sensors??????
 

·
Premium Member
Joined
·
3,847 Posts
here's idea #1.... get it out of the shop where it's at and bring it to someone who knows what they're doing.

If they're hunting around & replacing shit to try & diagnose an electrical problem (ie guessing) , they're not qualified.
 

·
Registered
Joined
·
96 Posts
if the FI light is coming on, a qualified shop will have the tool to read the fault code from the ecu.
Yeah like a paperclip
 

·
Registered
Joined
·
5 Posts
Discussion Starter · #6 ·
The shop it was at have taken it to a Suzuki Dealers who ran a full diagnostics on it and nothing came back component-wise....

It runs for about 30 mins from cold, then 5 - 10 seconds if you try and start it up again.

Starting to get fed up with this....... its been sunny all week and I'm confined to 4 wheels!!!!!
 

·
Registered
Joined
·
15 Posts
Hi, on the left side of the tail you can find two connectors one have only two cables. You have to shortcut this two cables using a paperclip like suggested and switch on the ignition.
where before you had the indication of the engine temperature you'll find a code like this -Cxx where xx is the number of fault.
With this number you can understand where is the problem.

If FI signal is flashing you have to find a fault code.
 
1 - 7 of 7 Posts
Top