Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 10 of 10 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter #1
Anyone had any experience with delkavic or have one on ther bike? I did have one on my old cbr 600 and thought the quality and sound was pretty good!

I'm looking at getting one for the k7 1000 but I want to see pictures and video's first in anyone has one.

Cheers
 

·
Premium Member
Joined
·
164 Posts
I'm actually curious about this too. My bike came with a shorty slip-on muffler when I bought it used. That muffler could blow the eardrums out of an elephant from 20 miles away. I waned to throw on a quieter slip-on until I chose a good quality system. Their price point is obviously attractive but also wonder what people's experiences have been. You always get what you pay for but I'm glad you were impressed with the one on your 600. Delkavic seems to be very proud of their product with a decent warranty. I think they only make slip-ons for the K7/K8. Youtube has plenty of videos from GSXR 1000's but I wouldn't judge the sound by them. You don't know what device was used to record it, how far away from the exhaust the recording was, was it recorded outside or in a garage, etc. As you already know each muffler length and DB insert plays a role in sound. You also have to consider the playback device your using to judge the sound. Good quality computer system speakers are going to sound different than smart phone ear buds. Hope things work out for you. Keep us posted. Thanks.

Motorcycles - Suzuki - 2008 Models - GSX-R1000 (2007-2008) - Delkevic
 

·
Registered
2007 Suzuki GSX-R 1000
Joined
·
61 Posts
My K7 1000 with full full titanium exhaust and a shorty Delkavic muffler. Really happy with look and sound.
573423
 

·
Registered
2007 Suzuki GSX-R 1000
Joined
·
61 Posts
I always have problems on forms with videos, pictures etc.. I was able to post those two pictures but how do you post a video? Does it have to be below a certain file size? I'm working on my bike right now so I can help you out.
 

·
Registered
Joined
·
39 Posts
Discussion Starter #7
I always have problems on forms with videos, pictures etc.. I was able to post those two pictures but how do you post a video? Does it have to be below a certain file size? I'm working on my bike right now so I can help you out.
I'm not sure myself tbh, you could upload it to something like dropbox or YouTube then paste the link here?
 

·
Registered
2007 Suzuki GSX-R 1000
Joined
·
61 Posts
I was going to get the video of my bike doing a little revving so you could hear what it sounds like parked and started revving her to about 8-9k two or three times and a 11-12k once and the bike dies. I think the last time I just revved the engine (I don't sit on my bike a and rev it with a reason) I got a code. I don't remember which one because when you turn the bike off and back on its like it never happened... runs great! When I'm riding the engine doesn't skip a beat, it only dies when I sit and rev it while its in neutral. I am guessing I have an electrical problem with amps/volts/watts (ohms?) rapidly changing because of the revs and/or a bad connection which is making it short out and die.
So if you or anyone could lead me to some spots to check and troubleshoot that would be helpful. I am pretty good with a wrench so ask me any questions that might help the fix. Thank you
573439

573440

573441
 

·
Registered
2007 Suzuki GSX-R 1000
Joined
·
61 Posts
Dyno chart from their website. I hope to dyno my bike in the next month or two and see numbers like this.
573511
 
1 - 10 of 10 Posts
Top