Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 13 of 13 Posts

·
Registered
Joined
·
520 Posts
Discussion Starter #1
would 2.2 dyna coils work on my 87 1100? or do i need different ones? thanx
 

·
Banned
Joined
·
3,509 Posts
After asking the same question of the people at Dyna...The answer is YES.

The 2.2 ohm (part #DC4-1) is what you're looking to have. Give them a call at 626.963.1669 if you have other concerns.
 

·
Registered
Joined
·
139 Posts
Man, You guy's just scared the crap out of me! (even more than those clowns) I've got the 3 OHM Dyna's on my 86 1100 and I could have sworn the guy told me not to use the 2.2's. Well, I just gave them a call, and yes the 2.2's are recomended (Stock ignition or dyna 2000) But, if your running a Power Pak (like me), its the 3.0'S! Whew! (I really didnt want to buy a new set of coils)
Anyway, great information guys, and very accurate.

Thanks, and keep up the good work!
Dave.
 

·
Registered
Joined
·
139 Posts
Jeff,
You are the man!
I love it when electronics smoke! (As long as their not mine that is!)
 

·
Registered
Joined
·
17,099 Posts
if you're using the stock ecu, you're technically supposed to use the 3 ohm coils.....using ones that have a lower primary winding resistance can theoretically cause problems. realistically, people have gotten away with using 2.2's with no issues....

in case anybody's wondering, using 1 ohm ignition coils with the stock ecu will cause you to go through ignition fuses at the rate of about one every two minutes or so.

(don't ask.
)
 

·
Premium Member
Joined
·
372 Posts
does anyone have instructions for the dyna 2000 , and which coils are the green ones?
 

·
Registered
Joined
·
106 Posts
what's the going price on those? I think that could be the reason I keep fouling plugs on my 86-1100. I think the ones that are on there are Excells or something like that. They are canary yellow. has anyone had experience with those ?
 

·
Registered
Joined
·
50 Posts
Hi everybody I'm happy to find you guys and I hope you can help. I have an 86 750 and just reciently I have started noticing power lags and in the last few days the tach would die and I would experance extreme powerloss but the bike would still run. I think one of my coils is going but after testing with a meter it looks fine. if it is a coil problem which Dyna should I replace it with.
My gixxer is mostly orignal mechanicly.
Thanks for any help Phil
 

·
Registered
Joined
·
17,099 Posts
Originally posted by Chango1:
what's the going price on those? I think that could be the reason I keep fouling plugs on my 86-1100. I think the ones that are on there are Excells or something like that. They are canary yellow. has anyone had experience with those ?
<font size="2" face="Verdana, Arial">i haven't heard anything really bad about the excels....if you're fouling all of your plugs constantly, the problem isn't likely to be the coils.

if i remember correctly, i paid around $50-60 each for dynas, but that was several years ago.
 

·
Registered
Joined
·
17,099 Posts
Originally posted by pcpalmer:
Hi everybody I'm happy to find you guys and I hope you can help. I have an 86 750 and just reciently I have started noticing power lags and in the last few days the tach would die and I would experance extreme powerloss but the bike would still run. I think one of my coils is going but after testing with a meter it looks fine. if it is a coil problem which Dyna should I replace it with.
My gixxer is mostly orignal mechanicly.
Thanks for any help Phil
<font size="2" face="Verdana, Arial">next time you lose power on your bike, try spraying the headers with a spray bottle filled with water to see which cylinders are misfiring....it could clue you in on which coil is going bad (if it's even a coil problem at all).
 
1 - 13 of 13 Posts
Top