Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 14 of 14 Posts

·
Registered
Joined
·
146 Posts
Discussion Starter · #1 ·
i just put a factory pro jet kit in my 97 gixxer 750, and i just finally got the midrange and topend nice, but now i have another problem. we got the bike adjusted and took it out for a ride, and the bike was doing fine.. till i cracked it open to full throttle, 11,000 plus rpm, and then let off.. it crackled and backfired and whatnot, and then it started dying when i gave it throttle. eventually it died, and i sat for 3-4 minutes cranking the starter, till i guess it dried out the carbs. i'm guessing they flooded or something, but it was just from being on high rpm's and then letting off. also the bike has been not dropping rpm's after giving it throttle. the mixture screws are set at 4 turns out right now, so i dont know if they should be out more or what... i found that it will now stop EXACTLY at 3 grand, and not drop anymore unless i engage a gear and manually slow the rpm's down. anyone think they can help or add any wisdom to this nightmare? i am at 5000ft above sea level, inside main jet-127.5, outside 130, mixture screws 4 turns out, needle clip position at 4th notch. please help me out...
 

·
Registered
Joined
·
1,284 Posts
Hey mang - I'm no jetting expert, but it sounds like your mixture screws are a bit far out.. you might want to check out www.factorypro.com - they have a really good jetting howto on there. Sorry I can't help you more, I'm working on my carbs myself


- G
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #3 ·
yea.. the factory pro site helped out a little bit, but now it seems like something is really messed up, and i was hoping someone else went through this already...
 

·
Highly unstable
Joined
·
32,025 Posts
sounds to me like your running lean. the rpms hanging up off idle certainly seems like a lean condition. try turning the mixtures screws out a half turn more. also make sure you have no intake leaks. if you have a leak that will create the same situation. make sure you have your diaphrams set properly also. and make sure you dont have a tear in one of them.
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #5 ·
the thing is though.. i have tried them at 3.5 turns out, 4 turns out, and just today i tried 1.5 turns out, and 2 turns out.. and i still have the same situation... i hope its not a vaccum problem
 

·
Registered
Joined
·
645 Posts
those vacuum leaks can be a real pain. They can cause your bike to not even run, or they can cause it to idle too high all the time. Depending of course on what vacuum source the leak is coming from. You did replace the springs in the carbs too from the Factory kit right? They'll help with mainly the flaps of the butterflies... but just checking. The other thing is consulting the manual and double checking all your connections. Carbs will take some tuning. You may find flat spots too sometimes where you don't like them, but you'll find over time when you become really good at fine tuning them, that they can be adjusted out too. Keep posting on your progress. I'd like to hear what you're doing to fix the issue.
 

·
Registered
Joined
·
553 Posts
Like bmfgsxr said, a vacuum leak is quite possible. Internally, they are fairly easy to check. Just make sure the diaphragm is in good condition (no tears) and that it seats on the carb body properly. Externally, do a spray test. Spray water from a small mister bottle on each intake rubber and listen for a stumble in revs. No stumble is no leak, a stumble denotes an air leak.

I'm excactly where you are right now, trying to remove a lean condition that is causing me a rev hang-up and an erractic idle. So, I know just how you fell on this one. Let us know your progress....

Dave.
 

·
Registered
Joined
·
146 Posts
Discussion Starter · #10 ·
i'll go give the carbs the vaccum leak test, and pray that is the only problem. thanks for the opinions everyone!
 

·
Registered
Joined
·
35 Posts
replace ur plugs check and make sure ur jets are tuned right too the after market exahust...if the gap is wrong on the plugs that will cause a miss fire or backfire
 

·
Registered
Joined
·
585 Posts
Vacumn leak.. make sure that the little tiny O-rings under the diaphram cap are still there. They fall out very easily when you're putting the caps back on.
 

·
Registered
Joined
·
71 Posts
Tell us more about the bike, exaust? Air Filter-Stock? I am running a 97 at 4500 foot and I have the following mods, Yosh RS3 Duplex Race full system, K&N Filter +3 timing advance. I am running the 132.5/130/130/132.5 with the needles on the 3rd and the air screw 2.5 out. Did you get the 1.1 or the 1.7 kit? Which idle jets are you running? I am running the 17.5 from the kit and my bike runs great. I also have a fuel mixture gauge, and it runs right in the middle except for full throttle when it is on the richer side, but still in stoich range.
 

·
Registered
Joined
·
297 Posts
I live in Calgary, elevation 3442 feet

My set up is:

96 GSXR 750 streetfighter
mild port and polish
5 angle valve job
K&N filter
Yosh RS3 'race' slip on
Dynojet kit stage 1 with this set up:
132 - 130 - 130 -132
Needles on 4th clip
3.5 turns out
6.5 mm float height

i'm due for a carb synch as well

i still get some bogging on the low revs when the engine gets hot... i would like to work out the flat spots and stuff.

suggestions are very welcome!!!!

for this winter I think i'll be installing DYNA ignition coils and a manual cam chain tensioner and then get onto the aestetic stuff finally.
 
1 - 14 of 14 Posts
Top