Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 10 of 10 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter #1
I have 2001 1st gen hayabusa I’m exp rider my ? Is this when I’m in first I’m all good at bout 80-90mph but I try to give full throttle is spudders or Boggs down same when Im in 4-5-6 gear any suggestions on what might be the reason I just passed 15,000 on it it’s the greatest bike I will never buy another ever I’m busa all the way just would love to get it’s full potential out of betty that’s her name cause she’s all black if some has had the problem or might know please help thank again ride safe stay up god bless all us riders
 

·
Captain Obvious ... because obviously it’s obvious
Joined
·
3,940 Posts
Holy run-on sentence.

Do a fuel flow test.
 

·
Super Moderator
Joined
·
17,110 Posts
This section is for help with the functionality of the website.
It has NOTHING to do with bike related questions.

I am moving this to the proper bike specific section of the site..(y)
 

·
Registered
Joined
·
5 Posts
I had a similar issue with my 06 gsxr 750. I tried eveything, threw money at it for nothing. My bike would sputter like it was choking between 6k rpms and all the way up, but if i pin the throttle wide open itll pull and go like it should. Found out to be my secondary butterfly's were not fully functioning correctly, changed the TPS for oem and it ran perfect. Trust me, i did spark plugs, coils, fuel flow test, fuel filter, air filter, ran sea foam through it, checked for kinks, man you name it. I was stupid enough to think a power commander would "fix it".
 

·
Registered
Joined
·
5 Posts
Discussion Starter #7
I had a similar issue with my 06 gsxr 750. I tried eveything, threw money at it for nothing. My bike would sputter like it was choking between 6k rpms and all the way up, but if i pin the throttle wide open itll pull and go like it should. Found out to be my secondary butterfly's were not fully functioning correctly, changed the TPS for oem and it ran perfect. Trust me, i did spark plugs, coils, fuel flow test, fuel filter, air filter, ran sea foam through it, checked for kinks, man you name it. I was stupid enough to think a power commander would "fix it".
I’m ordering I also noticed I have black carbon sute in my pipes I’ve had the bike for 2 yrs just pasted 15,000 miles she’s such a great bike I worked in the oil field I wish I had put more money into it when I had it saved but TPS is 75.00 so I’m gonna buy that I’ll keep you posted after you changed it was that all that was. Wrong it
 

·
Registered
Joined
·
5 Posts
I also did have a lot of black soot in my exhaust, like an excessive amount. Black smoke would shoot out when i gave it full throttle. The primary wasnt matcing the secondary mid range when the secondarys are suppose to start opening up, but they didnt. I think it has to something inside the tps where it wouldnt fully turn like it has a resistance. But it works fine now.
 

·
Registered
Joined
·
5 Posts
The reason being you see all that black soot is obviously it being too rich. The secondarys arent letting enough air into the system and when you keep giving it more and more throttle/gas, itll cause all that black soot. Which also i believe causes it to bog/sputter/choke.
 

·
Registered
Joined
·
5 Posts
Discussion Starter #10
The reason being you see all that black soot is obviously it being too rich. The secondarys arent letting enough air into the system and when you keep giving it more and more throttle/gas, itll cause all that black soot. Which also i believe causes it to bog/sputter/choke.
I don’t have smoke coming out just build up on the end of the pipe it runs good other tyat sotter at full trottke but it is fast and has oick yo I’m not sure what to do I’m research more tomorrow
 
1 - 10 of 10 Posts
Top