Suzuki GSX-R Motorcycle Forums Gixxer.com banner
1 - 3 of 3 Posts

·
Registered
Joined
·
2 Posts
Discussion Starter · #1 ·
I have a 1999 GSXR-750 and the ignition fuse blew. I put a new one in there and it i drove the bike around for a few minutes and it worked fine, brought it home parked it let it sit for an hour, then when i started it up again the motor started then died and the fuse was blown again. If anyone has any idea of where to start looking for the problem or if you need more info on the problem let me know. Any info would be great thanks.
 

·
Registered
Joined
·
4,747 Posts
i think i can solve this prob...is it the main 30 amp green fuse? if so check 3 things... 1. the connections at the battery pos and neg and at the frame (ground/neg) if thats tight then try your connections especially the main connector which is located under the left side fairing..see if its corrided inside spray some contact cleaner in there either way to be sure and finally fi thats not it then 3. check for any exposed wires around the left fairing and also around the fork tubes and under the ignition. more then likely that will solve your problem. if not then im stumped! hope this helps you. good luck!
 

·
Registered
Joined
·
582 Posts
i think i know exactly what your talkinga bout..its 10rating fuse not a 30..thats the main fuse..and when you start it it will blow im guessing ebcause theres a exposed wire in your steering column..goto checker or some store buy a 10 pack of fuses and first try to start the bike with the handlebars locked left and if it blows..you can hear it..open up the fuse box by the steering column to hear it..also then try to start it up with the handle bars locked to the right..if it doesnt blow theres a exposed wire somewhere in that steering column...check around because thats probably what it is.
 
1 - 3 of 3 Posts
Top