Suzuki GSX-R Motorcycle Forums Gixxer.com banner

1 - 3 of 3 Posts

·
Registered
Joined
·
1 Posts
Discussion Starter #1
I was riding my bike for like 6 hours perfectly fine. I parked it and went to start it again about an hour later and it would not start.

The FI light is solid red and the dash says CHEK. I have tried to get a dealer code but one will not come up. I checked most of the safety features to see what the issue was but did not find anything.

When I turn the key to on and turn the killswitch on the injectors usually start to prime. That is no longer happening anymore.

Please help. I really want to get back to riding.
 

·
You should listen to me. No, seriously, listen to
Joined
·
7,563 Posts
The red LED is a general fault indicator that is turned on when the oil pressure is low, i.e. the engine isn't running. CHEC means that the cluster isn't getting data from the ECM, normally because the ECM isn't getting power. With the ignition on, check the voltage at the R lead on the eight pin SAP connector. It should be 5 V. You could also check the voltage at the W/R lead to the dealer mode connector. It should be something other than zero, but I'm not sure what. The problem commonly is with the side-stand switch or the kill switch. Will it crank? See the diagram on 7-10 of the service manual. Have you checked your fuses, particularly IGNITION?
 

·
Registered
Joined
·
38 Posts
Not sure if you fixed the issue but I had almost the same issue a week ago. I would be out riding and the bike would just cut off. Power was still on but the dash would say CHEC while the kill switch was in the run position. Means the ECM is not communicating with the dash. The issue I had was the plug coming from the kill switch going into the main harness was bad. The orange with white wire that loops was not making a good contact. I could start the bike and jiggle the connector and the bike would shut off. I ordered a pigtail connector set of of Amazon and replaced the stock one from the kill switch and the harness side. Instantly fixed my issue. Been riding a week now and no issues.
 
1 - 3 of 3 Posts
About this Discussion
2 Replies
3 Participants
Trooper182
Suzuki GSX-R Motorcycle Forums Gixxer.com
A forum community dedicated to the Suzuki GSX-R motorcycle. Discuss the GSX-R600, GSX-R750, GSX-R1000, and GSX-R1100, and more!
Full Forum Listing
Top